<div dir="ltr"><div>(...)<br>>     Did not meet =dev-lang/perl-5.16*, use existing if possible,
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br><div id=":2mr" class="">
>        Did not meet =dev-lang/perl-5.18*, use existing if possible,
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>>        Did not meet >=dev-lang/perl-5.16, use existing if possible,
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)</div><br>It seems some packages require perl 5.16 some 5.18 (esp looking at messages at the bottom).<br></div><div><br>I would start with perl-cleaner first, and rebuild any package that requires old perl slots. VIrtuals can be uninstalled for now, they'll be restored automatically during next system update, hopefully with the correct dependencies.<br>
</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">2014-05-27 18:08 GMT+02:00 Andreas Gick <span dir="ltr"><<a href="mailto:andreasgick@web.de" target="_blank">andreasgick@web.de</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hi,<br>
<br>
trying to update dev-perl/WWW-RobotRules, cave complains:<br>
---------------------------------------------------------------------<br>
These are the actions I will take, in order:<br>
<br>
u   dev-perl/WWW-RobotRules:0::gentoo 6.20.0 to ::installed replacing<br>
6.10.0-r1<br>
    build_options: symbols=split -dwarf_compress -optional_tests -trace<br>
work=tidyup<br>
    Reasons: target, dev-perl/libwww-perl-6.50.0:0::installed<br>
    8.85 kBytes to download<br>
<br>
Total: 1 upgrades, 8.85 kBytes to download<br>
<br>
I encountered the following errors:<br>
<br>
!   dev-lang/perl<br>
    Reasons: !!<dev-lang/perl-5.8.8-r8 from<br>
perl-core/Encode-2.470.0:0::installed,<br>
app-admin/perl-cleaner-2.7:0::installed,<br>
app-text/qpdf-4.1.0:0::installed, 68 more<br>
    Unsuitable candidates:<br>
      * dev-lang/perl-5.12.3-r1:0::gentoo<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.12.4:0::gentoo<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.12.4-r1:0::gentoo<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.12.4-r2:0::gentoo<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.12.5:0::gentoo<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.14.1:0::gentoo<br>
        Masked by repository<br>
            Torsten Veller <<a href="mailto:tove@gentoo.org">tove@gentoo.org</a>> (18 Jun 2011) Mask<br>
perl-5.14. See tracker bug #356171<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.14.1-r1:0::gentoo<br>
        Masked by repository<br>
            Torsten Veller <<a href="mailto:tove@gentoo.org">tove@gentoo.org</a>> (18 Jun 2011) Mask<br>
perl-5.14. See tracker bug #356171<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.14.2:0::gentoo<br>
        Masked by repository<br>
            Torsten Veller <<a href="mailto:tove@gentoo.org">tove@gentoo.org</a>> (18 Jun 2011) Mask<br>
perl-5.14. See tracker bug #356171<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet >=dev-lang/perl-5.16, use existing if possible,<br>
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.16.0:0::gentoo<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.16.1:0::gentoo<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.16.2:0::gentoo<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
      * dev-lang/perl-5.16.2-r1:0::gentoo<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
      * dev-lang/perl-5.16.3:0::gentoo<br>
        Did not meet =dev-lang/perl-5.18*, use existing if possible,<br>
installing to / from virtual/perl-libnet-1.230.0:0::installed<br>
      * dev-lang/perl-5.18.2:0::gentoo<br>
        Did not meet =dev-lang/perl-5.16*, use existing if possible,<br>
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed<br>
        Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if<br>
possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed<br>
(and 2 more)<br>
----------------------------------------------------------------------------<br>
What I'd like to know is a systematic way to solve the problem of not<br>
finding a suitable dev-lang/perl version. In such cases I usually look<br>
at the package mentioned after "from" but this time there's more than one.<br>
<br>
Thanks in advance,<br>
<br>
Regards Andreas<br>
<br>
_______________________________________________<br>
paludis-user mailing list<br>
<a href="mailto:paludis-user@lists.exherbo.org">paludis-user@lists.exherbo.org</a><br>
<a href="http://lists.exherbo.org/mailman/listinfo/paludis-user" target="_blank">http://lists.exherbo.org/mailman/listinfo/paludis-user</a><br>
</blockquote></div><br></div>