[paludis-user] (Gentoo) `cave resolve --complete world` failed

Ciaran McCreesh ciaran.mccreesh at googlemail.com
Sun Apr 17 06:53:01 UTC 2016


On Sun, 17 Apr 2016 06:50:43 +0800
Zesen Qian <paludis-user at riaqn.com> wrote:
> But there 're still some errors, slot-related stuff. More
> specifically, all haskell packages(say A) 's version is like
> 0.1.2,3:0/0.1.2.3, and haskell packages(say B) depending on this
> library will have ">=B-0.1.0.0:=", so any version greater than
> 0.1.0.0 is good, but any changes in the slot will trigger a rebuilt
> of this package B. On portage this is well handled.
> 
> Paludis cannot handle this situation, and tell me that there's no
> candidate. Because I have A-0.1.2.3:0/0.1.2.3 installed, paludis
> insist that any A that's install-able to be in slot 0/0.1.2.3.

Paludis handles it correctly, and does exactly what you tell it to do
on the command line...

-- 
Ciaran McCreesh



More information about the paludis-user mailing list