[paludis-user] "Unsuitable candidates"-problem (dev-lang/perl)

marcin kowalski yoshi314 at gmail.com
Wed May 28 06:04:03 UTC 2014


(...)
>     Did not meet =dev-lang/perl-5.16*, use existing if possible,
installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>        Did not meet =dev-lang/perl-5.18*, use existing if possible,
installing to / from virtual/perl-libnet-1.230.0:0::installed
>        Did not meet >=dev-lang/perl-5.16, use existing if possible,
installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)

It seems some packages require perl 5.16 some 5.18 (esp looking at messages
at the bottom).

I would start with perl-cleaner first, and rebuild any package that
requires old perl slots. VIrtuals can be uninstalled for now, they'll be
restored automatically during next system update, hopefully with the
correct dependencies.


2014-05-27 18:08 GMT+02:00 Andreas Gick <andreasgick at web.de>:

> Hi,
>
> trying to update dev-perl/WWW-RobotRules, cave complains:
> ---------------------------------------------------------------------
> These are the actions I will take, in order:
>
> u   dev-perl/WWW-RobotRules:0::gentoo 6.20.0 to ::installed replacing
> 6.10.0-r1
>     build_options: symbols=split -dwarf_compress -optional_tests -trace
> work=tidyup
>     Reasons: target, dev-perl/libwww-perl-6.50.0:0::installed
>     8.85 kBytes to download
>
> Total: 1 upgrades, 8.85 kBytes to download
>
> I encountered the following errors:
>
> !   dev-lang/perl
>     Reasons: !!<dev-lang/perl-5.8.8-r8 from
> perl-core/Encode-2.470.0:0::installed,
> app-admin/perl-cleaner-2.7:0::installed,
> app-text/qpdf-4.1.0:0::installed, 68 more
>     Unsuitable candidates:
>       * dev-lang/perl-5.12.3-r1:0::gentoo
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.12.4:0::gentoo
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.12.4-r1:0::gentoo
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.12.4-r2:0::gentoo
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.12.5:0::gentoo
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.14.1:0::gentoo
>         Masked by repository
>             Torsten Veller <tove at gentoo.org> (18 Jun 2011) Mask
> perl-5.14. See tracker bug #356171
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.14.1-r1:0::gentoo
>         Masked by repository
>             Torsten Veller <tove at gentoo.org> (18 Jun 2011) Mask
> perl-5.14. See tracker bug #356171
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.14.2:0::gentoo
>         Masked by repository
>             Torsten Veller <tove at gentoo.org> (18 Jun 2011) Mask
> perl-5.14. See tracker bug #356171
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet >=dev-lang/perl-5.16, use existing if possible,
> installing to / from dev-perl/URI-1.600.0:0::installed (and 8 more)
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.16.0:0::gentoo
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.16.1:0::gentoo
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.16.2:0::gentoo
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>       * dev-lang/perl-5.16.2-r1:0::gentoo
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>       * dev-lang/perl-5.16.3:0::gentoo
>         Did not meet =dev-lang/perl-5.18*, use existing if possible,
> installing to / from virtual/perl-libnet-1.230.0:0::installed
>       * dev-lang/perl-5.18.2:0::gentoo
>         Did not meet =dev-lang/perl-5.16*, use existing if possible,
> installing to / from virtual/perl-MIME-Base64-3.130.0-r2:0::installed
>         Did not meet dev-lang/perl:0/5.16=[-build(-)], use existing if
> possible, installing to / from dev-perl/libwww-perl-6.50.0:0::installed
> (and 2 more)
>
> ----------------------------------------------------------------------------
> What I'd like to know is a systematic way to solve the problem of not
> finding a suitable dev-lang/perl version. In such cases I usually look
> at the package mentioned after "from" but this time there's more than one.
>
> Thanks in advance,
>
> Regards Andreas
>
> _______________________________________________
> paludis-user mailing list
> paludis-user at lists.exherbo.org
> http://lists.exherbo.org/mailman/listinfo/paludis-user
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20140528/3bd9c92c/attachment-0001.html>


More information about the paludis-user mailing list