[paludis-user] failed pbin install, cannot load saved environment

doc.holliday at usa.com doc.holliday at usa.com
Sun May 25 18:19:42 UTC 2014


>Andrej Filipcic wrote:
>>
>> Hi,
>>
>> I have a problem installing gentoo pbin dev-python/reportlab-2.6
>>
>> this command (pbins are in f9bin overlay)
>> cave resolve -1z -Cs --via-binary '*/*' --hide '*/*::f9bin'
>> dev-python/reportlab -x
>> shows the messages at the bottom of this email.
>>
>> I tried to manually setup the env and run scrub function in verbose mode
>> and it fails when it encounters BASHPID env:
>
>In /usr/libexec/paludis/source_functions.bash, line 45, in the
>ebuild_safe_source function, add BASHPID to the list of variables, then
>see if that fixes the install.
>
>What version of bash are you using?

I am having a similar problem with few other packages (eg, gettext, llvm and others) and I can confirm that adding BASHPID to source_functions.bash handles it. See http://bpaste.net/show/298335/ for example.

bash version is 4.2.45(1)-release



More information about the paludis-user mailing list