[paludis-user] paludis pulling unneeded dependencies

Rodolphe Rocca maitrechang at gmail.com
Thu Jan 30 15:11:21 UTC 2014


Hi,

I have noticed a suspicious behavior for a long time, but now I get the
time to write about it.

The fact is on some packages paludis is pulling some dependencies on the
lattest slot while nothing on the system seems to require this specific
slot for the specific package.

Actually "paludis report" detects that the system has no dependencies on
these packages, so i run "paludis purge" and those packages are purged.

But then I run "cave resolve -c" and bang, paludis wants to reinstall them.

This happens with goocanvas :

$ cave show goocanvas
* x11-libs/goocanvas
    ::gentoo                  1.0.0 {:0} 2.0.1 2.0.1-r1(~) 2.0.2* {:2.0}
    ::installed               1.0.0 {:0}


$ equery d goocanvas
 * These packages depend on goocanvas:
dev-python/pygoocanvas-0.14.1-r1 (>=x11-libs/goocanvas-0.14:0)


$ cave resolve -c installed-packages -X goocanvas

...

s   x11-libs/goocanvas:2.0::gentoo 2.0.2 to ::installed
    "Canvas widget for GTK+ using the cairo 2D library for drawing"
    -examples introspection python PYTHON_TARGETS: -python2_6 python2_7
build_options: symbols=split -dwarf_compress -optional_tests -trace
work=tidyup
    Reasons: target (installed-packages::installed)

...

Explaining requested decisions:

For x11-libs/goocanvas:2.0::(install_to_slash):
    The following constraints were in action:
      * x11-libs/goocanvas, use existing if same, installing to /
        Because of target (installed-packages::installed)
    The decision made was:
        Use origin ID x11-libs/goocanvas-2.0.2:2.0::gentoo
        Install to repository installed
Executing pretend actions: 14 of 14



It also happens with a dozen packages :
 - wxpython (need :2.8 but pulls :3.0)
 - gtk-engines-xfce
 - swt (need 3.7 but pulls 4.2-r2)
 - spidermonkey (need :0 but pulls :2.0)

Any odea ?

Thanks !

--
Rodolphe Rocca



More information about the paludis-user mailing list