[paludis-user] question about dependencies

Ciaran McCreesh ciaran.mccreesh at googlemail.com
Mon Nov 11 20:13:11 UTC 2013


On Mon, 11 Nov 2013 09:40:27 +0100
OndraK <ondrej.kajinek at gmail.com> wrote:
> I installed gentoo-sources manually (virtual/linux-kernel is not
> involved), there is no package depending on gentoo-sources (according
> to "cave print-dependent-ids"). This paludis' behaviour is kind of
> "strange" to me: "sys-kernel/gentoo-sources" record in world file
> does not let paludis to uninstall the older version. I am curious,
> and would like to know something "from behind the scene", if you
> could find some time to answer my question which may be a silly one.

A dependency with no explicit slot or slot operator specified is
treated as meaning "and we don't know which slot", so for safety we
assume "potentially any slot".

> Can a package manager (speaking about flawless one) use only the
> latest (best, or whatever we call it) version of package when a
> "category/package" is the only dependency on that package?

It could, but doing so would be unsafe for dependencies that don't have
a :* operator.

-- 
Ciaran McCreesh
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20131111/509a040f/attachment.asc>


More information about the paludis-user mailing list