[paludis-dev] [Paludis] #1360: Gentoo news : Unsupported News-Item-Format '2.0'

Paludis trac-paludis at exherbo.org
Sun Oct 8 08:41:05 UTC 2017


#1360: Gentoo news : Unsupported News-Item-Format '2.0'
---------------------------+--------------------------
    Reporter:  MageSlayer  |       Type:  defect
      Status:  new         |   Priority:  Sometime
   Milestone:              |  Component:  clients/cave
     Version:  2.4.0       |   Keywords:
  Blocked By:              |   Blocking:
Distribution:  N/A         |
---------------------------+--------------------------
 Hi

 It looks like news format in Gentoo changed quite long ago.
 Could paludis/cave be taught to understand it?
 Currently it just emits:
 {{{
 cave at 1507449715: [WARNING e.news.skipping] In thread ID '27998':
   ... In program cave execute-resolution --preserve-world --world-specs
 media-libs/libpng:0/16 libpng:0/16:
   ... When executing chosen resolution:
   ... When triggering hook 'install_all_post':
   ... When performing hook 'install_all_post' for repository 'gentoo':
   ... When updating news at location
 '/var/paludis/repositories/portage/metadata/news' for repository 'gentoo':
   ... When handling news entry
 '/var/paludis/repositories/portage/metadata/news/2017-04-10-split-and-
 slotted-wine':
   ... Skipping news item
 '/var/paludis/repositories/portage/metadata/news/2017-04-10-split-and-
 slotted-wine' because of exception 'Error in news file
 '/var/paludis/repositories/portage/metadata/news/2017-04-10-split-and-
 slotted-wine/2017-04-10-split-and-slotted-wine.en.txt': Unsupported News-
 Item-Format '2.0'' (paludis::NewsError)
 cave at 1507449715: [WARNING e.news.skipping] In thread ID '27998':
   ... In program cave execute-resolution --preserve-world --world-specs
 media-libs/libpng:0/16 libpng:0/16:
   ... When executing chosen resolution:
   ... When triggering hook 'install_all_post':
   ... When performing hook 'install_all_post' for repository 'gentoo':
   ... When updating news at location
 '/var/paludis/repositories/portage/metadata/news' for repository 'gentoo':
   ... When handling news entry
 '/var/paludis/repositories/portage/metadata/news/2017-07-16-systemd-
 rootprefix':
   ... Skipping news item
 '/var/paludis/repositories/portage/metadata/news/2017-07-16-systemd-
 rootprefix' because of exception 'Error in news file
 '/var/paludis/repositories/portage/metadata/news/2017-07-16-systemd-
 rootprefix/2017-07-16-systemd-rootprefix.en.txt': Unsupported News-Item-
 Format '2.0'' (paludis::NewsError)
 cave at 1507449715: [WARNING e.news.skipping] In thread ID '27998':
   ... In program cave execute-resolution --preserve-world --world-specs
 media-libs/libpng:0/16 libpng:0/16:
   ... When executing chosen resolution:
   ... When triggering hook 'install_all_post':
   ... When performing hook 'install_all_post' for repository 'gentoo':
   ... When updating news at location
 '/var/paludis/repositories/portage/metadata/news' for repository 'gentoo':
   ... When handling news entry
 '/var/paludis/repositories/portage/metadata/news/2017-08-19-hardened-
 sources-removal':
   ... Skipping news item
 '/var/paludis/repositories/portage/metadata/news/2017-08-19-hardened-
 sources-removal' because of exception 'Error in news file
 '/var/paludis/repositories/portage/metadata/news/2017-08-19-hardened-
 sources-removal/2017-08-19-hardened-sources-removal.en.txt': Unsupported
 News-Item-Format '2.0'' (paludis::NewsError)
 cave at 1507449715: [WARNING e.news.skipping] In thread ID '27998':
   ... In program cave execute-resolution --preserve-world --world-specs
 media-libs/libpng:0/16 libpng:0/16:
   ... When executing chosen resolution:
   ... When triggering hook 'install_all_post':
   ... When performing hook 'install_all_post' for repository 'gentoo':
   ... When updating news at location
 '/var/paludis/repositories/portage/metadata/news' for repository 'gentoo':
   ... When handling news entry
 '/var/paludis/repositories/portage/metadata/news/2017-10-04-gentoolkit-
 dev-deprecation':
   ... Skipping news item
 '/var/paludis/repositories/portage/metadata/news/2017-10-04-gentoolkit-
 dev-deprecation' because of exception 'Error in news file
 '/var/paludis/repositories/portage/metadata/news/2017-10-04-gentoolkit-
 dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt': Unsupported
 News-Item-Format '2.0'' (paludis::NewsError)
 }}}

 Tested under Gentoo x64 and paludis-9999

-- 
Ticket URL: <http://paludis.exherbo.org/trac/ticket/1360>
Paludis <http://paludis.exherbo.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list