[paludis-dev] [Paludis] #1358: Recent paludis does not understand Gentoo security

Paludis trac-paludis at exherbo.org
Wed Aug 2 13:07:39 UTC 2017


#1358: Recent paludis does not understand Gentoo security
-----------------------------+--------------------
    Reporter:  MageSlayer    |      Owner:
        Type:  defect        |     Status:  closed
    Priority:  Sometime      |  Milestone:
   Component:  clients/cave  |    Version:  scm
  Resolution:  upstream      |   Keywords:
  Blocked By:                |   Blocking:
Distribution:  N/A           |
-----------------------------+--------------------

Comment (by zimous):

 I have just attached a simple patch which fixes the problem.  Please let
 me argue a bit and consider reopening.  The code for GLSAs is
 Gentoo/ebuild specific and its sole purpose is to support Gentoo.  If it
 does not work with real world GLSAs you could drop the support entirely.
 Secondly, the fix is rather trivial (whether you like my patch or not).

 Of course I will ask also for fixing the GLSAs on the Gentoo side too.  I
 basically agree with you that it's the GLSAs which are incorrect.  Are you
 sure that SLOT="" is invalid, could you please point me to some spec?

-- 
Ticket URL: <http://paludis.exherbo.org/trac/ticket/1358#comment:2>
Paludis <http://paludis.exherbo.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list