[paludis-dev] [Paludis] #1324: Be less awful than Portage for REQUIRED_USE errors

Paludis trac-paludis at exherbo.org
Sun Mar 1 22:30:58 UTC 2015


#1324: Be less awful than Portage for REQUIRED_USE errors
-----------------------------+--------------------
    Reporter:  ant           |      Owner:
        Type:  enhancement   |     Status:  closed
    Priority:  Sometime      |  Milestone:
   Component:  clients/cave  |    Version:  2.2.0
  Resolution:  upstream      |   Keywords:
  Blocked By:                |   Blocking:
Distribution:  Gentoo        |
-----------------------------+--------------------
Changes (by ciaranm):

 * status:  new => closed
 * resolution:   => upstream


Comment:

 Nope. REQUIRED_USE is broken by design: it doesn't give us enough
 information to give a good error or to suggest a resolution. The fix is
 for everyone to stop using it in favour of pkg_pretend.

-- 
Ticket URL: <http://paludis.exherbo.org/trac/ticket/1324#comment:1>
Paludis <http://paludis.exherbo.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list