[paludis-dev] [Paludis] #1307: "cave import" does not allow same version installed in multiple slots

Paludis trac-paludis at exherbo.org
Sat May 31 23:34:16 UTC 2014


#1307: "cave import" does not allow same version installed in multiple slots
-----------------------------+--------------------
    Reporter:  cjm           |      Owner:
        Type:  defect        |     Status:  new
    Priority:  MinorRelease  |  Milestone:
   Component:  clients/cave  |    Version:  1.4.2
  Resolution:                |   Keywords:  import
  Blocked By:                |   Blocking:
Distribution:  N/A           |
-----------------------------+--------------------

Comment (by cjm):

 I've found that a workaround is to use revision numbers on the versions:
 {{{
 cave import -x -r1 --location /tmp/slot1 testing/import 1.1-r1 1
 cave import -x -r1 --location /tmp/slot2 testing/import 1.1-r2 2
 }}}
 works as expected.  It doesn't really matter what the revision numbers are
 as long as they're different.

-- 
Ticket URL: <http://paludis.exherbo.org/trac/ticket/1307#comment:1>
Paludis <http://paludis.exherbo.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list