[paludis-dev] [Paludis] #1258: cave uninstall of specific version wants to uninstall all versions

Paludis trac-paludis at exherbo.org
Fri Nov 2 18:06:51 UTC 2012


#1258: cave uninstall of specific version wants to uninstall all versions
-----------------------------+--------------------
    Reporter:  zaufi         |      Owner:
        Type:  defect        |     Status:  closed
    Priority:  Sometime      |  Milestone:
   Component:  clients/cave  |    Version:  0.80.2
  Resolution:  invalid       |   Keywords:
  Blocked By:                |   Blocking:
Distribution:  N/A           |
-----------------------------+--------------------
Changes (by ciaranm):

 * status:  new => closed
 * resolution:   => invalid


Comment:

 This is intentional. Ebuilds operate on the assumption that there can only
 be one thing per name:slot installed. If somehow you end up violating that
 assumption (which you shouldn't really be able to do), you can either do a
 'cave resolve boost-build', which will replace both installed versions
 (which ebuilds are supposed to handle correctly), or you can use 'cave
 perform' (which might lead to breakage).

-- 
Ticket URL: <http://paludis.exherbo.org/trac/ticket/1258#comment:1>
Paludis <http://paludis.exherbo.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list