[paludis-dev] [Paludis] #1250: paludis 0.74.1 wants to install perl-5.12.4 even if perl-5.12.3-r1 is installed

Paludis trac-paludis at exherbo.org
Mon Jun 11 21:32:37 UTC 2012


#1250: paludis 0.74.1 wants to install perl-5.12.4 even if perl-5.12.3-r1 is
installed
-----------------------+--------------------------
    Reporter:  jmanig  |       Type:  defect
      Status:  new     |   Priority:  Sometime
   Milestone:          |  Component:  clients/cave
     Version:  0.74.1  |   Keywords:
  Blocked By:          |   Blocking:
Distribution:  N/A     |
-----------------------+--------------------------
 I'm trying to install virtual/perl-Compress-Raw-Zlib:0::gentoo which has
 in its RDEPEND "|| ( ~dev-lang/perl-5.12.4 ~dev-lang/perl-5.12.3 ~dev-
 lang/perl-5.12.2 ~perl-core/Compress-Raw-Zlib-2.024 )". paludis 0.74.1
 insists on installing perl-5.12.4-r1 eventhough I have perl-5.12.3-r1
 installed. It works fine in paludis 0.72.2.

 This breaks my installation attempt of git[cgi], as perl-Digest-MD5 does
 not work with perl-5.12.4.

-- 
Ticket URL: <http://paludis.exherbo.org/trac/ticket/1250>
Paludis <http://paludis.exherbo.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list