[paludis-dev] [Paludis] #1165: Improve cave resolve "Unsuitable canditates:" output.

Paludis trac at pioto.org
Mon May 16 19:56:23 UTC 2011


#1165: Improve cave resolve "Unsuitable canditates:" output.
--------------------------+-----------------------
 Reporter:  sera          |         Owner:
     Type:  defect        |        Status:  new
 Priority:  Sometime      |     Milestone:
Component:  clients/cave  |       Version:  0.60.4
 Keywords:                |    Blocked By:
 Blocking:                |  Distribution:  N/A
--------------------------+-----------------------
 See attachment for output of all commands.

 Excerpt actual output of cave resolve:
 {{{
 !   dev-java/netbeans-harness
     Reasons: dev-util/netbeans
     Unsuitable candidates:
       * dev-java/netbeans-harness-9999_p20110508:9999::layman (in
 ::fordfrog)
         Masked by unavailable (In a repository which is unavailable)
         Did not meet ~dev-java/netbeans-harness-7.0, use existing if
 possible, installing to / from dev-util/netbeans
       * dev-java/netbeans-harness-9999_p20110512:9999::layman (in
 ::fordfrog)
         Masked by unavailable (In a repository which is unavailable)
         Did not meet ~dev-java/netbeans-harness-7.0, use existing if
 possible, installing to / from dev-util/netbeans
 }}}

 Suggesting dev-java/netbeans-harness-7.0:7.0::gentoo seems to be the only
 reasonable choice here even so it's keyword masked. cave resolve lists the
 others.

-- 
Ticket URL: <http://trac.pioto.org/paludis/ticket/1165>
Paludis <http://paludis.pioto.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list