[paludis-sekrit] [Paludis] #879: ~ requirements caches in upgrade/downgrade cycle

Paludis trac at pioto.org
Sun Apr 25 22:22:33 UTC 2010


#879: ~ requirements caches in upgrade/downgrade cycle
-----------------------------+----------------------------------------------
 Reporter:  uzytkownik       |          Owner:        
     Type:  defect           |         Status:  new   
 Priority:  Sometime         |      Milestone:        
Component:  clients/paludis  |        Version:  0.46.0
 Keywords:                   |      Blockedby:        
 Blocking:                   |   Distribution:  Gentoo
-----------------------------+----------------------------------------------
 If ~dependency are used in every update of world by:
 {{{
 paludis -i1 world --continue-on-failure if-independent --dl-reinstall if-
 use-changed --dl-reinstall-scm weekly
 }}}

 Package is upgraded/downgraded. For example if:

  1. dev-lang/ghc-6.12.2 is the newest in repositories
  2. ~dev-lang/ghc-6.12.1 is required by dev-haskell/haskell-
 platform-2010.1.0.0.
  3. dev-haskell/haskell-platform is in world
  4. Then if dev-lang/ghc-6.12.1 is installed it is upgraded to dev-
 lang/ghc-6.12.2 and if dev-lang/ghc-6.12.2 is installed it is downgraded
 to dev-lang/ghc-6.12.1.

-- 
Ticket URL: <http://trac.pioto.org/paludis/ticket/879>
Paludis <http://paludis.pioto.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list