[paludis-sekrit] [Paludis] #515: paludis is willing to upgrade and downgrade the same package.

Paludis trac at pioto.org
Mon Nov 16 00:46:04 UTC 2009


#515: paludis is willing to upgrade and downgrade the same package.
-----------------------------+----------------------------------------------
 Reporter:  whereami         |          Owner:  ciaranm
     Type:  defect           |         Status:  new    
 Priority:  Sometime         |      Milestone:         
Component:  clients/paludis  |        Version:  0.42.2 
 Keywords:                   |      Blockedby:         
 Blocking:                   |   Distribution:  Gentoo 
-----------------------------+----------------------------------------------
Changes (by whereami):

  * distribution:  => Gentoo
  * version:  0.26.0_alpha9 => 0.42.2


Comment:

 I just hit this again, this time with xorg-server 1.7.1 and 1.6.5.

 xorg-x11-7.4-r1 wants xserver 1.7.1, but nvidia-drivers-185.18.36-r1 (the
 most recent that I've unmasked in keywords.conf) wants 1.6.5.

 This bug has been open for nearly 2 years. When can we expect this
 mythical new resolver? Can you at least make it an error to merge the same
 package/slot twice in one run, or something??

 selected output of paludis -pi1 xorg-x11 --show-reasons full
 {{{
 * x11-base/xorg-server [U 1.6.5 -> 1.7.1]
     Reasons: x11-base/xorg-x11-7.4-r1:0::gentoo, x11-drivers/xf86-input-
 evdev-2.3.0:0::gentoo,
 x11-drivers/xf86-input-keyboard-1.4.0:0::installed, x11-drivers/xf86
 -input-mouse-1.5.0:0::installed,
 x11-drivers/xf86-video-vesa-2.2.1:0::installed
     -debug -dmx hal ipv6 -kdrive -minimal nptl -sdl* -tslib xorg
 build_options: -optional_tests
 split strip -trace
 * x11-base/xorg-server [R 1.6.5]
     Reasons: x11-base/xorg-x11-7.4-r1:0::gentoo,
 x11-drivers/nvidia-drivers-185.18.36-r1:0::gentoo
     -debug -dmx hal ipv6 -kdrive -minimal nptl -sdl* -tslib xorg
 build_options: -optional_tests
 split strip -trace

 }}}

-- 
Ticket URL: <http://trac.pioto.org/paludis/ticket/515#comment:2>
Paludis <http://paludis.pioto.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list