[paludis-sekrit] [Paludis] #785: installed-unpackaged package not meeting requirements

Paludis trac at pioto.org
Fri Aug 14 20:38:26 UTC 2009


#785: installed-unpackaged package not meeting requirements
-------------------------------+--------------------------------------------
 Reporter:  cjm                |          Owner:        
     Type:  defect             |         Status:  new   
 Priority:  Sometime           |      Milestone:        
Component:  clients/importare  |        Version:  0.38.2
 Keywords:                     |      Blockedby:        
 Blocking:                     |   Distribution:  Gentoo
-------------------------------+--------------------------------------------
 I'm getting strange behavior after using importare to install a virtual
 /perl-Time-Local package.

 I used importare to install Perl 5.10.1-RC1.  I then did

 {{{
 importare -1 --location /tmp/empty virtual/perl-Time-Local 1.19.01 -R
 '>=unpackaged/perl-5.10'
 }}}

 because 5.10.1 includes Time-Local 1.19.01.  Then I tried updating www-
 misc/awstats, which has a simple RDEPEND on
 virtual/perl-Time-Local (no version number).

 Paludis said:
 {{{
 * virtual/perl-Time-Local::gentoo (previously ::unpackaged) [N 1.18]
     Reasons: www-misc/awstats-6.9-r1:0::gentoo
     build_options: -optional_tests split strip
     "Virtual for Time-Local"
 }}}

 It's downgrading from 1.19.01 to 1.18, but it's reporting it as a New
 install (despite also saying "previously ::unpackaged").  I just don't
 understand that.

 I removed the importare-created virtual/perl-Time-Local-1.19.01 package,
 created a virtual/perl-Time-Local-1.19.01 ebuild in /usr/local/portage,
 and installed that.  That worked as expected, and satisfied the www-
 misc/awstats RDEPEND.

 I thought that packages created through importare were supposed to be
 equivalent to those created through paludis.  What I was trying to do is
 supposed to work, right?

-- 
Ticket URL: <http://trac.pioto.org/paludis/ticket/785>
Paludis <http://paludis.pioto.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list