[paludis-sekrit] [Paludis] #616: Ruby Paludis.so linked against previous version of libpaludisnoconfigenvironment.so.26

Paludis trac at trac.pioto.org
Thu Jul 10 01:47:51 UTC 2008


#616: Ruby Paludis.so linked against previous version of
libpaludisnoconfigenvironment.so.26
---------------------------+------------------------------------------------
 Reporter:  damm           |          Owner:        
     Type:  defect         |         Status:  new   
 Priority:  Sometime       |      Milestone:        
Component:  bindings/ruby  |        Version:  0.28.0
 Keywords:                 |      Blockedby:        
 Blocking:                 |   Distribution:  Gentoo
---------------------------+------------------------------------------------
 in irb, or any ruby script that require 'Paludis' you get this handy
 error.

 /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/Paludis.so:
 libpaludisnoconfigenvironment.so.26: cannot open shared object file: No
 such file or directory -
 /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/Paludis.so (LoadError)
         from
 /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
         from /usr/bin/pint:12

 Reproduce:

 Upgrade using Paludis from 0.26.2 to 0.28.0

 Easy fix,

 paludis -i paludis

 Not even close to a solid fix, I didn't watch the build process even from
 0.26.2 to 0.28.0 but I'm sure you already know about this, but I didn't
 see an ticket on it :(

-- 
Ticket URL: <http://trac.pioto.org/paludis/ticket/616>
Paludis <http://paludis.pioto.org/>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list