[paludis-sekrit] [Paludis] #512: Wrong behaviour when uninstalling a slotted package

Paludis trac at trac.pioto.org
Sun Feb 17 11:30:32 UTC 2008


#512: Wrong behaviour when uninstalling a slotted package
-----------------------------+----------------------------------------------
 Reporter:  jordan83         |       Owner:  ciaranm      
     Type:  defect           |      Status:  new          
 Priority:  Sometime         |   Milestone:               
Component:  clients/paludis  |     Version:  0.26.0_alpha9
 Keywords:                   |    Blocking:               
Blockedby:                   |  
-----------------------------+----------------------------------------------
 Hi,

 a couple of days ago I decided to give a try to antlr-3.0.1 since I wanted
 to compare it to javacc. I took the ebuild from the java-experimental
 overlay and I copied it into my local overlay.

 Note that antlr-2.7.7 was already present in my system.

 ''paludis -q antlr'' prints out this:
 {{{
 $ paludis -q antlr
 * dev-java/antlr
     gentoo:                  2.7.7 {:0}
     installed:               2.7.7 {:0} 3.0.1* {:3}
     local:                   3.0.1 {:3}
     Description:             A parser generator for C++, C#, Java, and
 Python
     Homepage:                http://www.antlr.org/
     Relevant USE flags:      (-elibc_FreeBSD) (-source) (-test)
     License:                 BSD
     Installed time:          Fri Feb 15 17:45:37 2008
     Source repository:       local
     Installed using:         paludis-0.26.0_alpha9

 }}}
 Today I decided to uninstall ''antlr-3.0.1'' and in the following box you
 can see what I get:

 {{{
 # paludis --with-unused-dependencies -u =dev-java/antlr-3.0.1
 Building unmerge list... done

 These packages will be uninstalled:

 * dev-java/ant-antlr-1.7.0::installed requires <dev-
 java/antlr-3.0.1::installed>
 * dev-java/stringtemplate-3.1_beta1::installed
 * dev-java/gjdoc-0.7.8::installed requires <dev-
 java/antlr-3.0.1::installed>
 * dev-java/antlr-3.0.1::installed


 Total: 2 packages and 2 errors
 Use either --with-dependencies or --permit-unsafe-uninstalls

 Cannot continue with uninstall due to the errors indicated above
 }}}
 Apparently Paludis does not realize that ''antlr-2.7.7'' is available
 among the installed packages, thus uninstalling version 3.0.1 wouldn't be
 a problem.

 Needlessly to say both ''dev-java/ant-antlr-1.7.0'' and ''dev-
 java/gjdoc-0.7.8'' are fine with any version of antlr >=2.7.5-r3 (ant-
 antlr) and >=2.7.1 (gjdoc).

 My PALUDIS_OPTIONS looks like this:

 {{{
 # echo $PALUDIS_OPTIONS
 --log-level warning --dl-upgrade as-needed --dl-reinstall if-use-changed
 --show-use-descriptions changed --show-reasons summary
 }}}

-- 
Ticket URL: <http://paludis.pioto.org/trac/ticket/512>
Paludis <http://paludis.pioto.org/trac>
Paludis, the Other Package Mangler


More information about the paludis-dev mailing list