[Exherbo-dev] RFC: Switch default "jpeg" provider to jpeg-turbo

Marc-Antoine Perennou keruspe at exherbo.org
Wed Mar 30 19:54:51 UTC 2016


Hi,

On 30 March 2016 at 19:36, Heiko Becker <heirecka at exherbo.org> wrote:
> Hi,
>
> On 30.03.2016 18:06, Calvin Walton wrote:
>> After zlin reported on IRC about a test failure when using "ijg-jpeg"
>> implementation that don't happen for people using "jpeg-turbo", I was
>> wondering why our default jpeg provider is still the ijg library.
>>
>> Many other distributions have switched to using jpeg-turbo (at least by
>> default), including Debian, Ubuntu, Fedora, RHEL, SUSE. As a result, a
>> lot of current software isn't well tested with that library.
>
> this not only leads to failed tests, but quite some build failures with
> jpeg:9 (qtwebengine, OpenSceneGraph, calligra to name a few). One
> upstream has even closed a bug report about such an error with WONTFIX
> (They accepted a patch later on though).
>
>> As a bonus, jpeg-turbo has committed to maintaining abi stability - no
>> more rebuilding lots of packages with a new major jpeg library release.
>>
>> And so I propose to change the default provider used in Exherbo to
>> jpeg-turbo. Does anyone have any objections to that?
>
> On the contrary, a big, fat +1 from me. Thanks for bringing this up.

Same here, big +1

>
> Cheers,
> Heiko
>
> _______________________________________________
> Exherbo-dev mailing list
> Exherbo-dev at lists.exherbo.org
> http://lists.exherbo.org/mailman/listinfo/exherbo-dev



More information about the Exherbo-dev mailing list