[Exherbo-dev] Why is kde-workspace depending on net-apps/NetworkManager[>=0.7.0&<0.9]?

Ivan Lazar Miljenovic ivan.miljenovic at gmail.com
Wed Sep 5 01:34:40 UTC 2012


On 5 September 2012 09:00, Maciej Grela <maciej.grela at gmail.com> wrote:
> Hi,
>
> I've recently installed exherbo after being a long-time Gentoo user
> and I must say I like it a lot more :). However, during a recent
> update I discovered a puzzling fact. When I ran 'cave resolve -zx
> world' to update my system cave ended up suggesting a downgrade of
> networkmanager from 0.9.6.0 to 0.8.4.0-r2. I tracked it down to the
> kde-workspace package having the following requirement in DEPENDENCIES
> (in kde-workspace.exlib):
>
>         networkmanager? ( net-apps/NetworkManager[>=0.7.0&<0.9] )
>
> Why is the NetworkManager version restricted in this way? I suspected
> some incompatibility but I've googled for some time and I couldn't
> find any mention of it. Also, I'm running now kde-workspace-4.8.5 and
> NetworkManager-0.9.6 and it seems to work OK. Can anyone tell me what
> is the reason for this dependency to disallow having together
> kde-workspace-4.* and networkmanager-0.9*?

As of 4.6.3, it seems that only 0.7.* and 0.8.* were supported in the
default branch of solid: https://bugs.kde.org/show_bug.cgi?id=271289

I'm not sure if this has changed since (and thus the exheres dep needs
to be updated) or if it's still the case.

>
>
> Regards,
> Maciej Grela
>
> _______________________________________________
> Exherbo-dev mailing list
> Exherbo-dev at lists.exherbo.org
> http://lists.exherbo.org/mailman/listinfo/exherbo-dev



-- 
Ivan Lazar Miljenovic
Ivan.Miljenovic at gmail.com
http://IvanMiljenovic.wordpress.com



More information about the Exherbo-dev mailing list