[Exherbo-dev] Why is kde-workspace depending on net-apps/NetworkManager[>=0.7.0&<0.9]?

Maciej Grela maciej.grela at gmail.com
Tue Sep 4 23:00:50 UTC 2012


Hi,

I've recently installed exherbo after being a long-time Gentoo user
and I must say I like it a lot more :). However, during a recent
update I discovered a puzzling fact. When I ran 'cave resolve -zx
world' to update my system cave ended up suggesting a downgrade of
networkmanager from 0.9.6.0 to 0.8.4.0-r2. I tracked it down to the
kde-workspace package having the following requirement in DEPENDENCIES
(in kde-workspace.exlib):

        networkmanager? ( net-apps/NetworkManager[>=0.7.0&<0.9] )

Why is the NetworkManager version restricted in this way? I suspected
some incompatibility but I've googled for some time and I couldn't
find any mention of it. Also, I'm running now kde-workspace-4.8.5 and
NetworkManager-0.9.6 and it seems to work OK. Can anyone tell me what
is the reason for this dependency to disallow having together
kde-workspace-4.* and networkmanager-0.9*?


Regards,
Maciej Grela



More information about the Exherbo-dev mailing list