[Exherbo-dev] gmp and mpfr migration path

Paul Seidler pl.seidler at googlemail.com
Wed May 9 21:13:07 UTC 2012


Because of all the rev-bumps, Benedikt is right, simply update your
installed packages but don't run "uninstall" with the
"--uninstalls-may-break" parameter, if there are still packages which
depend on gmp/mpfr without ":=" fix them.

Greetings
Paul

Am Samstag, den 05.05.2012, 12:40 +0200 schrieb Benedikt Morbach:
> fwiw, I did this yesterday and it worked flawlessly.
> 
> A few packages still broke, but those were non-critical and got fixed
> by 'cave fix-linkage':
> dev-libs/gnutls-3.0.19:0::arbor
> dev-libs/glib-networking-2.32.1:0::arbor
> gnome-bindings/seed-3.2.0-r1:0::gnome
> 
> Also, a few exheres outside ::arbor arre missing := deps.
> For me those were:
> gnome-bindings/seed-3.2.0-r1:0::gnome
> sci-libs/glpk-4.47:0::scientific
> 
> But I deviated from the given upgrade path and did the following
>   cave resolve world -c -...
>   cave uninstall 'gmp:0' 'mpfr:0' --uninstalls-may-break '*/*'
>   cave fix-linkage
> 
> because the fix-linkage call given tried to rebuild everything again.





More information about the Exherbo-dev mailing list