[Exherbo-dev] GNOME3: Release v2.91.6 and gtk+-2.99.3 upgrade path

Brett Witherspoon spoonb at exherbo.org
Mon Feb 7 13:22:33 GMT 2011


This notice only concerns those testing the masked development release
of GNOME3.

I will be pushing gtk+-2.99.3 and some of the other core packages from
the recent GNOME v2.91.6 release this evening or tommorow. Due to a
change in ABI you will need to rebuild all your applications which are
built against gtk3. You will need to be prepared to do this immediatly
following the gtk3 upgrade.

Here is a list of packages ( v2.90 or greater ) that currently build against gtk3:

dev-libs/libpeas
dev-libs/vte
gnome-desktop/dconf
gnome-desktop/eog
gnome-desktop/evince
gnome-desktop/evolution-data-server
gnome-desktop/file-roller
gnome-desktop/gcalctool
gnome-desktop/gdm
gnome-desktop/gnome-bluetooth
gnome-desktop/gnome-control-center
gnome-desktop/gnome-desktop
gnome-desktop/gnome-keyring
gnome-desktop/gnome-power-manager
gnome-desktop/gnome-screensaver
gnome-desktop/gnome-session
gnome-desktop/gnome-settings-daemon
gnome-desktop/gnome-shell
gnome-desktop/gnome-terminal
gnome-desktop/gnome-themes-standard
gnome-desktop/gnome-utils
gnome-desktop/gtk-theme-engine-clearlooks
gnome-desktop/libgnome-media-profiles
gnome-desktop/libgnomekbd
gnome-desktop/mutter
gnome-desktop/nautilus
gnome-desktop/yelp
gnome-desktop/zenity
gnome-platform/GConf[=2.32.1]
media-libs/libcanberra
net-dns/avahi
net-im/empathy
net-libs/webkit
net-www/epiphany
x11-apps/notification-daemon
x11-libs/libnotify

There has also been a few minor changes in API which can break some
packages: However, the majority of those have already been taken care
of. If a package is broken please submit a patch in #exherbo. If you are
unsure how to fix it at least post a log.



More information about the Exherbo-dev mailing list