[Exherbo-dev] Unmasking GHC 7.0.4

Bernd Steinhauser exherbo at bernd-steinhauser.de
Wed Aug 3 14:41:13 BST 2011


On 03.08.2011 14:32, Markus Rothe wrote:
> On 3 August 2011 14:10, David Leverton<levertond at googlemail.com>  wrote:
>> On 3 August 2011 10:53, Ivan Lazar Miljenovic
>>> It shouldn't be, as long as you rebuild every package that is built on
>>> GHC.  I can see situations where this might be easier, however, if you
>>> forget to list a package to be rebuilt, then paludis/cave will know
>>> it's installed already but not that it was built with an older GHC: as
>>> such the dep resolution will be successful but the build will fail.
>> Haskell packages use := for the GHC dep, so Paludis knows which GHC
>> version they're built for.
> Yes, but the problem is that you aren't able to use the already
> installed packages with the new version of GHC.
>
> -Markus
Can't you just use --reinstall-dependents-of like it's done for perl?



More information about the Exherbo-dev mailing list