coffee71 at optimum.net
Tue Jun 22 01:34:39 BST 2010
I admit that this is an extremely minor point, but shouldn't the src_compile
phase really be called src_build since it not only compiles the source code
(producing the object files), but links those object files as well
(producing the final executable files)? This would also be more consistent
with DEPENDENCIES, where build dependencies are called "build" and
"built-against" rather than "compile" or "compiled-against". I know that
this suggestion would break a lot of existing exheres, but judging by what I
have seen so far, Exherbo has no problem with breaking things in the
short-term to make the distribution better in the long run, which is one of
the things I like about it ;-) . If what I have suggested is totally
ridiculous, feel free to redirect it to /dev/null and I won't take any
offense to it.
PS: Maybe src_prepare should be called src_patch since its main job seems
to be to apply patches via the expatch function. Then again, the
src_prepare name has the advantage of being more generic.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Exherbo-dev