[Exherbo-dev] can't install paludis after unpack currentr exherbo-x86 and chroot into it

Bernd Steinhauser exherbo at bernd-steinhauser.de
Wed Jun 17 22:03:43 BST 2009


Vasiliy G Tolstov wrote:
> Hello! 
> Today, after a long time i'm try to install paludis into new unpacked
> and chrooted environment of exherbo. Some time ago all work's fine, but
> now i get error:
> 
> selfip / # paludis -i paludis
> sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> Building target list... paludis at 1245267349: [WARNING
> repository.names_cache.unversioned] In thread ID '26602':
>   ... In program paludis -i paludis:
>   ... When performing install action from command line:
>   ... When adding install target 'paludis':
>   ... When parsing user package dep spec 'paludis':
>   ... When parsing generic package dep spec 'paludis':
>   ... When disambiguating package name 'paludis':
>   ... When finding all versions in some arbitrary order from packages
> matching */paludis with filter all matches filtered through supports
> action install:
>   ... When using name cache at '/var/cache/paludis/names/arbor':
>   ... Names cache for 'arbor' has no version information, so cannot be
> used. Either it was generated using an older Paludis version or it has
> not yet been generated. Perhaps you need to regenerate the cache using
> 'paludis --regenerate-installed-cache' or 'paludis
> --regenerate-installable-cache'?
> 
> sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> Building dependency list...
> 
> These packages will be installed:
> 
> * sys-apps/paludis::arbor [R scm] <target>
>     bash-completion -cran -doc inquisitio -pink -python -qa -ruby
> vim-syntax -xml -zsh-completion build_options: recommended_tests split
> strip
> 
> Total: 1 package (1 rebuild)
> 
> Checking for possible errors......
> sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
> 
> (1 of 1) Installing sys-apps/paludis-scm:0::arbor
> 
> Output
> log: /var/log/paludis/1245267350-install-sys-apps_paludis-scm:0::arbor.out
> 
> Unhandled exception:
>   * In program paludis -i paludis:
>   * When performing install action from command line:
>   * When executing install task:
>   * When installing 'sys-apps/paludis-scm:0::arbor' replacing
> { 'sys-apps/paludis-scm:0::installed' }:
>   * When running an ebuild command on 'sys-apps/paludis-scm:0::arbor':
>   * When running command '/usr/libexec/paludis/ebuild.bash
> '/var/db/paludis/repositories/arbor/packages/sys-apps/paludis/paludis-scm.exheres-0' killold':
>   * When creating pty FDs:
>   * posix_openpt(3) failed: No such file or directory
> (paludis::PtyError)
> 
> 
> I think that i have not some devices in my /dev, but a can't understand
> - that devices i miss 
> 1) xz -d exherbo-*.xz
> 2) mkdir exherbo
> 3) tar -C exherbo/ -xvf exherbo-*.tar
> 4) mount -t proc none exherbo/proc
> 5) mount -o bind /dev exherbo/dev
> 6) chroot exherbo /bin/babs; env-update.sh; source /etc/profile
> 7) chown -R
> paludisbuild:paludisbuild /var/cache/paludis /var/tmp/paludis; 
> 8) paludis -i paludis
> 
> Can You help me? Thank You for all tips and answers.
Hm, maybe you forgot to mount /dev/pts?
Try mount -o bind /dev/pts exherbo/dev/pts
Or mount -o rbind /dev exherbo/dev (instead of the command you used)

See the installation guide.

Regards,
Bernd



More information about the Exherbo-dev mailing list