[Exherbo-dev] Upcoming X.org changes

Gaute Hope eg at gaute.vetsj.com
Wed Jun 17 12:00:44 BST 2009


Keep xorg-server 1.5 for ati's catalyst 9.3 driver, later versions
don't work with cards after radeon hd 2000.

- gaute

Excerpts from Ingmar Vanhassel's message of ty. juni 16 03:22:06 +0200 2009:
> Hello list,
> 
> With the upcoming mesa-7.5 release, I'd like to replace the
> eclectic-opengl module (inherited from Gentoo) with an alternatives
> based solution. So far, I've ripped out the eclectic module, a
> preliminary patch is available at
> http://dev.exherbo.org/~ingmar/x11-add-mesa-7.5-remove-eselect-opengl.patch
> (This patch also includes mesa-7.5-rc3 with gallium bits).
> 
> I still have to work out the "use alternatives" part for libGL.so &
> friends. For this it would help if someone who's importared the
> ATI & nvidia blobs could mail me a contents listing of those packages.
> Thanks in advance.
> 
> Besides that, I've been meaning to clean up old versions of X11.
> If any newer versions of packages, drivers in particular, have serious
> regressions in newer versions, and there's a good reason to keep older
> versions, now's your time to yell before they're gone. We'll be happy to
> backport fixes from upstream.
> 
> -Ingmar



More information about the Exherbo-dev mailing list