<div dir="ltr">Hello,<div><br></div><div>I'm brand new to Paludis, and I've having some problems.</div><div><br></div><div>When I try to resolve world with cave resolve --complete -o '*/*' -d '*/*' world , I've got the following errors :</div>
<div><br></div><div><div>Done: 4555 steps, 5 metadata (5 fouxlay)                </div><div><br></div><div>These are the actions I will take, in order:</div><div><br></div><div>n   sys-apps/sdparm:0::gentoo 1.08-r1 to ::installed</div>
<div>    "Utility to output and modify parameters on a SCSI device, like hdparm"</div><div>    build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup</div><div>    Reasons: sys-apps/sg3_utils-1.37:0::installed</div>
<div>    317.63 kBytes to download</div><div><br></div><div>n   dev-python/rpyc:0::gentoo 3.2.3-r1 to ::installed</div><div>    "Remote Python Call (RPyC), a transparent and symmetric RPC library"</div><div>    PYTHON_TARGETS: -python2_6 python2_7 -python3_2 python3_3 build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup</div>
<div>    Reasons: net-misc/flexget-1.2.31:0::gentoo</div><div>    47.24 kBytes to download</div><div><br></div><div>n   dev-python/tmdb3:0::gentoo 0.6.17 to ::installed</div><div>    "TheMovieDB.org APIv3 interface"</div>
<div>    PYTHON_TARGETS: -python2_6 python2_7 build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup</div><div>    Reasons: net-misc/flexget-1.2.31:0::gentoo</div><div>    37.28 kBytes to download</div>
<div><br></div><div>d   net-misc/flexget:0::gentoo 1.2.31 to ::installed replacing 9999</div><div>    -transmission (-test) PYTHON_TARGETS: -python2_6 python2_7 build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup</div>
<div>    Reasons: target (world::environment)</div><div>    890.92 kBytes to download</div><div><br></div><div>Total: 1 downgrades, 3 new installs, 1.26 MBytes to download</div><div><br></div><div>I did not take the following:</div>
<div><br></div><div>(<) dev-python/paver 1.1.1-r1:0::installed</div><div>    Reasons: was used by net-misc/flexget-9999:0::installed</div><div>    Take using: --purge</div><div><br></div><div>Build Options:</div><div>    dwarf_compress:                Compress DWARF2+ debug information</div>
<div>    optional_tests:                Run tests considered by the package to be optional</div><div>    symbols:                       How to handle debug symbols in installed files</div><div>    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)</div>
<div>    work:                          Whether to preserve or remove working directories</div><div><br></div><div>python_targets:</div><div>    python2_6:                     Build with Python 2.6</div><div>    python2_7:                     Build with Python 2.7</div>
<div>    python3_2:                     Build with Python 3.2</div><div>    python3_3:                     Build with Python 3.3</div><div><br></div><div>I encountered the following errors:</div><div><br></div><div>!   sys-apps/portage</div>
<div>    Reasons: target (world::environment), !!<sys-apps/portage-2.1.9 from dev-lang/python-2.7.6:2.7::installed, !<sys-apps/portage-2.1.10.41 from app-misc/ca-certificates-20130906:0::installed, 6 more</div><div>
    Unsuitable candidates:</div><div>      * sys-apps/portage-2.1.6.7_p1:0::gentoo</div><div>        Masked by profile</div><div>            Andreas K. Huettel <<a href="mailto:dilfridge@gentoo.org">dilfridge@gentoo.org</a>> (14 Jan 2013) Mask portage versions not supporting EAPI=5</div>
<div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.1.11.62:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.1.12.2:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.2.1:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.2.6:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.2.7:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.2.8:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-2.2.8-r1:0::gentoo</div><div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>      * sys-apps/portage-9999:0::gentoo</div><div>        Masked by keyword</div><div>            Keywords </div>
<div>        Did not meet sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)], use existing if possible, installing to / from app-portage/flaggie-0.2.1:0::installed</div>
<div>            Flag 'python_single_target_python2_7' disabled, assuming disabled if missing</div><div>!   virtual/udev</div><div>    Reasons: dev-libs/libatasmart-0.19-r1:0::installed, dev-libs/libusbx-1.0.18:1::installed, gnome-base/gvfs-1.18.3:0::installed, 15 more</div>
<div>    Unsuitable candidates:</div><div>      * virtual/udev-208:0::gentoo</div><div>        Did not meet >=virtual/udev-197[gudev,hwdb], use existing if possible, installing to / from sys-fs/udisks-1.0.4-r5:0::installed</div>
<div>            Flag 'hwdb' enabled</div></div><div><br></div><div>I have really no idea on how to solve this.</div><div><br></div><div>I've tried reading all the manual pages, but really can't find any solutions.</div>
<div><br></div><div>Any idea?</div><div>Thanks.</div><div><div><br></div>-- <br>François-Xavier Payet<br><a href="mailto:fx.payet@tfdn.org" target="_blank">fx.payet@tfdn.org</a><br>Jabber : <a href="mailto:fx.payet@tfdn.org" target="_blank">fx.payet@tfdn.org</a>
</div></div>