[paludis-user] Migrating from Portage - Can't resolve world

François-Xavier Payet fx.payet at tfdn.org
Wed Feb 19 14:10:39 UTC 2014


Hello,

I'm brand new to Paludis, and I've having some problems.

When I try to resolve world with cave resolve --complete -o '*/*' -d '*/*'
world , I've got the following errors :

Done: 4555 steps, 5 metadata (5 fouxlay)

These are the actions I will take, in order:

n   sys-apps/sdparm:0::gentoo 1.08-r1 to ::installed
    "Utility to output and modify parameters on a SCSI device, like hdparm"
    build_options: symbols=split -dwarf_compress -optional_tests -trace
work=tidyup
    Reasons: sys-apps/sg3_utils-1.37:0::installed
    317.63 kBytes to download

n   dev-python/rpyc:0::gentoo 3.2.3-r1 to ::installed
    "Remote Python Call (RPyC), a transparent and symmetric RPC library"
    PYTHON_TARGETS: -python2_6 python2_7 -python3_2 python3_3
build_options: symbols=split -dwarf_compress -optional_tests -trace
work=tidyup
    Reasons: net-misc/flexget-1.2.31:0::gentoo
    47.24 kBytes to download

n   dev-python/tmdb3:0::gentoo 0.6.17 to ::installed
    "TheMovieDB.org APIv3 interface"
    PYTHON_TARGETS: -python2_6 python2_7 build_options: symbols=split
-dwarf_compress -optional_tests -trace work=tidyup
    Reasons: net-misc/flexget-1.2.31:0::gentoo
    37.28 kBytes to download

d   net-misc/flexget:0::gentoo 1.2.31 to ::installed replacing 9999
    -transmission (-test) PYTHON_TARGETS: -python2_6 python2_7
build_options: symbols=split -dwarf_compress -optional_tests -trace
work=tidyup
    Reasons: target (world::environment)
    890.92 kBytes to download

Total: 1 downgrades, 3 new installs, 1.26 MBytes to download

I did not take the following:

(<) dev-python/paver 1.1.1-r1:0::installed
    Reasons: was used by net-misc/flexget-9999:0::installed
    Take using: --purge

Build Options:
    dwarf_compress:                Compress DWARF2+ debug information
    optional_tests:                Run tests considered by the package to
be optional
    symbols:                       How to handle debug symbols in installed
files
    trace:                         Trace actions executed by the package
(very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working
directories

python_targets:
    python2_6:                     Build with Python 2.6
    python2_7:                     Build with Python 2.7
    python3_2:                     Build with Python 3.2
    python3_3:                     Build with Python 3.3

I encountered the following errors:

!   sys-apps/portage
    Reasons: target (world::environment), !!<sys-apps/portage-2.1.9 from
dev-lang/python-2.7.6:2.7::installed, !<sys-apps/portage-2.1.10.41 from
app-misc/ca-certificates-20130906:0::installed, 6 more
    Unsuitable candidates:
      * sys-apps/portage-2.1.6.7_p1:0::gentoo
        Masked by profile
            Andreas K. Huettel <dilfridge at gentoo.org> (14 Jan 2013) Mask
portage versions not supporting EAPI=5
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.1.11.62:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.1.12.2:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.2.1:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.2.6:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.2.7:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.2.8:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-2.2.8-r1:0::gentoo
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
      * sys-apps/portage-9999:0::gentoo
        Masked by keyword
            Keywords
        Did not meet
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),-python_single_target_pypy2_0(-)],
use existing if possible, installing to / from
app-portage/flaggie-0.2.1:0::installed
            Flag 'python_single_target_python2_7' disabled, assuming
disabled if missing
!   virtual/udev
    Reasons: dev-libs/libatasmart-0.19-r1:0::installed,
dev-libs/libusbx-1.0.18:1::installed, gnome-base/gvfs-1.18.3:0::installed,
15 more
    Unsuitable candidates:
      * virtual/udev-208:0::gentoo
        Did not meet >=virtual/udev-197[gudev,hwdb], use existing if
possible, installing to / from sys-fs/udisks-1.0.4-r5:0::installed
            Flag 'hwdb' enabled

I have really no idea on how to solve this.

I've tried reading all the manual pages, but really can't find any
solutions.

Any idea?
Thanks.

-- 
François-Xavier Payet
fx.payet at tfdn.org
Jabber : fx.payet at tfdn.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20140219/5d025383/attachment.html>


More information about the paludis-user mailing list