[paludis-user] Unsuitable candidates with no explanation

hasufell hasufell at gentoo.org
Sat Aug 2 15:51:25 UTC 2014


Ciaran McCreesh:
> On Fri, 1 Aug 2014 22:14:43 +0200
> Martin Sekera <sekerama at gmail.com> wrote:
>> I've been having unusual blockers lately, especially surrounding the
>> =perl-5.18 upgrade, but not exclusive to it.
> 
> Unfortunately Gentoo doesn't follow its own policies for perl, so these
> tend to be messy...
> 

Interestingly it seems that the perl project even uses
|| ( >=foo-1.3 ~bar-3.2 )

depstrings while there is no instance of bar-3.2 whatsoever in the tree.
Repoman doesn't complain about it and from what I read PMS doesn't mind
either:
"at least one immediate child element must be matched"

So that also results in some WONTFIX bugs
https://bugs.gentoo.org/show_bug.cgi?id=518660

I'm not sure if that depstring is a particularly good idea.



More information about the paludis-user mailing list