[paludis-user] Unable to install virtual/rubygems-6

Georgi Georgiev chutz at gg3.net
Thu Sep 12 15:44:41 UTC 2013


Quoting Georgi Georgiev at 12/09/2013-22:04:07(+0900):
> Quoting Eduardo Suarez-Santana at 12/09/2013-10:03:32(+0100):
> > On Thu, Sep 12, 2013 at 8:24 AM, Georgi Georgiev <chutz at gg3.net> wrote:
> > 
> > > I understand that virtual/rubygems-6 only has the "ruby_targets_ruby20"
> > > flag enabled. But I already have the ruby18 and ruby19 versions
> > > installed, so why doesn't paludis let me install a different slot
> > > anyway.
> > >
> > 
> > I had a similar problem. I could just enable one ruby target.
> > 
> > # use.conf
> > */* RUBY_TARGETS: -* ruby19
> > 
> > # package_mask.conf
> > dev-lang/ruby:2.0
> > virtual/rubygems:ruby20
> > ~dev-ruby/rubygems-2.0.3
> > ~dev-ruby/json-1.8.0
> > ~dev-ruby/racc-1.4.9
> > ~dev-ruby/rake-0.9.6
> > ~dev-ruby/rdoc-4.0.1
> 
> Thanks. I saw that the ruby20 target is now being forced in the profile
> so I thought I cannot *not* install that target. It didn't occur to me
> to just mask the versions that actually use it.

Well, your suggestion gave me a slightly simpler idea. I simply added
"ruby_targets_ruby20" to use.mask in my personal repository. This way I
don't have to mask the latest versions of the dev-ruby/* packages.

-- 
(    Georgi Georgiev   (  Narrator: Aww, we forgive you, Buttercup.  (



More information about the paludis-user mailing list