[paludis-user] || dependencies, dev-lang/perl and virtual/perl-i18n-langtags

Ciaran McCreesh ciaran.mccreesh at googlemail.com
Wed Aug 14 22:47:56 UTC 2013


On Tue, 13 Aug 2013 22:08:17 +0300
Alexandros Diamantidis <adia at hellug.gr> wrote:
>     Run dependencies          
>                               || (
>                                   ~dev-lang/perl-5.12.4
>                                   ~dev-lang/perl-5.12.3
>                                   ~dev-lang/perl-5.12.2
>                                   ~dev-lang/perl-5.10.1
>                                   ~dev-lang/perl-5.8.8
>                                   ~perl-core/i18n-langtags-0.35
>                               )
> 
> perl-core/i18n-langtags-0.35 is already installed... so why aren't
> virtual/perl-i18n-langtags's dependencies satisfied?

A || dependency doesn't mean "or". It means "prefer the first one that
isn't masked".

-- 
Ciaran McCreesh
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20130814/ed760326/attachment.asc>


More information about the paludis-user mailing list