[paludis-user] Trouble with (seemingly) too-strict dependencies

Taahir Ahmed ahmedtd at tamu.edu
Mon Apr 29 19:58:21 UTC 2013


What is the way I should work around this, then?  Is the resolution to submit 
a patch to the ebuild maintainer?

The gentoo-sources packages are blocking my system upgrades via cave, which 
may be another separate issue.

Taahir Ahmed

On Monday 29 April 2013 20:12:31 Ciaran McCreesh wrote:
> On Mon, 29 Apr 2013 14:03:32 -0500
> Taahir Ahmed <ahmedtd at tamu.edu> wrote:
> > I have recently switched my Gentoo system to using paludis/cave, and
> > I have run into two similar problems.
> > 
> > The first is that I cannot uninstall any currently-installed version
> > of sys- kernel/gentoo-sources without also allowing (via
> > --uninstalls-may-break or -- remove-if-dependent) cave to take
> > virtual/linux-sources (and along with that, nearly half the system).
> 
> That's down to how ebuilds are specifying dependencies: if they don't
> explicitly give a slot, or a :* specifier, then we don't know which
> slots are affected. Rather than risk breakage, we err on the side of
> caution, and assume that all slots are required unless ebuilds
> explicitly say otherwise.
> 
> 



More information about the paludis-user mailing list