[paludis-user] libreoffice-bin is blocked by libreoffice ?

denisgolovan denisgolovan at yandex.ru
Sat Oct 6 08:03:27 UTC 2012


Hi

Currently I am trying to install app-office/libreoffice-bin-3.5.5.3 and I am getting a strange blocking error.
See youself:

======================================================
$ cave resolve --lazy libreoffice-bin
Done: 1600 steps               

These are the actions I will take, in order:

n   app-office/libreoffice-l10n:0::gentoo 3.5.6 to ::installed
    "Translations for the Libreoffice suite."
    -offlinehelp LINGUAS: -af -ar -as -ast -be -bg -bn -bo -br -brx -bs -ca -ca_XV -cs -cy -da -de -dgo -dz -el en -en_GB -en_ZA -eo -es -et -e
u -fa -fi -fr -ga -gd -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -kok -ks -ku -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -n
b -ne -nl -nn -nr -nso -oc -om -or -pa_IN -pl -pt -pt_BR -ro ru -rw -sa_IN -sat -sd -sh -si -sk -sl -sq -sr -ss -st -sv -sw_TZ -ta -te -tg -th-
tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh_CN -zh_TW -zu build_options: -optional_tests -trace work=tidyup                                    
    Reasons: app-office/libreoffice-bin-3.5.5.3:0::gentoo
    2.64 MBytes to download
u   app-text/libexttextcat:0::gentoo 3.3.1 to ::installed replacing 3.2.0
    -static-libs build_options: symbols=strip -optional_tests -trace work=tidyup
    Reasons: app-office/libreoffice-bin-3.5.5.3:0::gentoo
    964.91 kBytes to download
n   dev-cpp/libcmis:0.2::gentoo 0.1.0-r1 to ::installed
    "C++ client library for the CMIS interface"
    -static-libs (-test) build_options: symbols=strip (-optional_tests) -trace work=tidyup
    Reasons: app-office/libreoffice-bin-3.5.5.3:0::gentoo
n   app-office/libreoffice-bin:0::gentoo 3.5.5.3 to ::installed
    "LibreOffice, a full office productivity suite. Binary package."
    (-aqua) cups -debug -gnome -java -kde build_options: (-optional_tests) -trace work=tidyup
    Reasons: target
    71.65 MBytes to download

Total: 1 upgrades, 3 new installs, 75.23 MBytes to download

Build Options:
    optional_tests:                Run tests considered by the package to be optional
    symbols:                       How to handle debug symbols in installed files
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working directories

I encountered the following errors:

!   app-office/libreoffice
    Reasons: !app-office/libreoffice from app-office/libreoffice-bin-3.5.5.3:0::gentoo, app-office/libreoffice-l10n-3.5.6:0::gentoo
    Unsuitable candidates:
      * app-office/libreoffice-3.5.6.2:0::gentoo
        Did not meet !app-office/libreoffice, use existing if possible, installing to / (nothing is fine too) from !app-office/libreoffice from
 app-office/libreoffice-bin-3.5.5.3:0::gentoo                                                                                                 
      * app-office/libreoffice-3.6.2.2:0::gentoo
        Masked by keyword
            Keywords ~amd64 ~amd64-linux ~ppc ~x86 ~x86-linux
        Did not meet !app-office/libreoffice, use existing if possible, installing to / (nothing is fine too) from !app-office/libreoffice from
 app-office/libreoffice-bin-3.5.5.3:0::gentoo                                                                                                 
      * app-office/libreoffice-3.6.9999:0::gentoo
        Masked by keyword
            Keywords 
        Did not meet !app-office/libreoffice, use existing if possible, installing to / (nothing is fine too) from !app-office/libreoffice from
 app-office/libreoffice-bin-3.5.5.3:0::gentoo                                                                                                 
      * app-office/libreoffice-9999-r2:0::gentoo
        Masked by keyword
            Keywords 
        Did not meet !app-office/libreoffice, use existing if possible, installing to / (nothing is fine too) from !app-office/libreoffice from
 app-office/libreoffice-bin-3.5.5.3:0::gentoo
=============================================

It looks like cave thinks I have app-office/libreoffice installed.
But I don't:

$ cave uninstall app-office/libreoffice

Error:
  * In program cave uninstall app-office/libreoffice:
  * Found nothing suitable matching 'app-office/libreoffice' (paludis::cave::NothingMatching)

I also checked my package database:
$ ls -1 /var/db/pkg/app-office/
mdbtools-0.6_pre2-r2
qtstalker-0.36

Somebody help :)

P.S. I am using paludis-0.80.0

 -- 
Regards,
Denis Golovan aka MageSlayer



More information about the paludis-user mailing list