[paludis-user] Strange problem

David Carlos Manuelda stormbyte at gmail.com
Wed Nov 7 13:55:10 UTC 2012


El Wed, 7 Nov 2012 12:23:18 +0000
Ciaran McCreesh <ciaran.mccreesh at googlemail.com> escribió:
> On Wed, 7 Nov 2012 12:22:58 +0100
> David Carlos Manuelda <stormbyte at gmail.com> wrote:
> > > cave show -ci dev-db/sqlite-3.7.14.1:3::installed and look to see
> > > what the EAPI is. Subslots aren't legal in EAPIs other than 5.
> > 
> > Huh?
> > cave show dev-db/sqlite-3.7.14.1:3::installed
> 
> Sorry, missing an = sign.
> 

This is the full output:
cave show -ci =dev-db/sqlite-3.7.14.1:3::installed
* =dev-db/sqlite-3.7.14.1:3::installed
    ::installed               3.7.14.1 {:3}
    dev-db/sqlite-3.7.14.1:3::installed
    Description               A SQL Database Engine in a C Library
    Homepage                  http://sqlite.org/
    From repositories         gentoo
    Installed time            Tue Nov 06 12:40:05 CET 2012
    License                   public-domain
    Use flags                 
        USE                   
            (-alpha)          
            (amd64)           
            (-amd64-fbsd)     
            (-amd64-linux)    
            (-arm)            
            (-arm-linux)      
            (-debug)          
            (-doc)            
            (-elibc_AIX)      
            (-elibc_Cygwin)   
            (-elibc_Darwin)   
            (-elibc_FreeBSD)  
            (-elibc_HPUX)     
            (-elibc_Interix)  
            (-elibc_NetBSD)   
            (-elibc_OpenBSD)  
            (-elibc_SunOS)    
            (-elibc_Winnt)    
            (elibc_glibc)     
            (-elibc_mintlib)  
            (-elibc_uclibc)   
            (extensions)      
            (fts3)            
            (-hppa)           
            (-hppa-hpux)      
            (-ia64)           
            (-ia64-hpux)      
            (-ia64-linux)     
            (icu)             
            (-kernel_AIX)     
            (-kernel_Cygwin)  
            (-kernel_Darwin)  
            (-kernel_FreeBSD) 
            (-kernel_HPUX)    
            (-kernel_Interix) 
            (-kernel_NetBSD)  
            (-kernel_OpenBSD) 
            (-kernel_SunOS)   
            (-kernel_Winnt)   
            (-kernel_freemint) 
            (kernel_linux)    
            (-m68k)           
            (-m68k-mint)      
            (-mips)           
            (-ppc)            
            (-ppc-aix)        
            (-ppc-macos)      
            (-ppc-openbsd)    
            (-ppc64)          
            (-ppc64-linux)    
            (-prefix)         
            (readline)        
            (-s390)           
            (-secure-delete)  
            (-sh)             
            (-soundex)        
            (-sparc)          
            (-sparc-fbsd)     
            (-sparc-solaris)  
            (-sparc64-freebsd) 
            (-sparc64-solaris) 
            (-tcl)            
            (threadsafe)      
            (-unlock-notify)  
            (-userland_BSD)   
            (userland_GNU)    
            (-x64-freebsd)    
            (-x64-macos)      
            (-x64-openbsd)    
            (-x64-solaris)    
            (-x86)            
            (-x86-cygwin)     
            (-x86-fbsd)       
            (-x86-freebsd)    
            (-x86-interix)    
            (-x86-linux)      
            (-x86-macos)      
            (-x86-netbsd)     
            (-x86-openbsd)    
            (-x86-solaris)    
            (-x86-winnt)      
            (-test)           
        Build Options         
            -trace            Trace actions executed by the package
(very noisy, for debugging broken builds only) Build
dependencies        

Error:
  * In program cave show -ci =dev-db/sqlite-3.7.14.1:3::installed:
  * When parsing metadata key 'DEPEND' from
'dev-db/sqlite-3.7.14.1:3::installed':
  * When parsing 'dev-libs/icu:0/0= sys-libs/readline ||
( >=sys-devel/automake-1.11.1:1.11 >=sys-devel/automake-1.12:1.12 )
>=sys-devel/autoconf-2.68 sys-devel/libtool':
  * When parsing from offset '0':
  * When parsing elike package dep spec 'dev-libs/icu:0/0=':
  * When parsing generic package dep spec 'dev-libs/icu:0/0=':
  * Name '0/0' is not a valid slot name (paludis::SlotNameError)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20121107/d2bc68ea/attachment.asc>


More information about the paludis-user mailing list