[paludis-user] Keep old stotted packages installed (KDE)

rozelak at volny.cz rozelak at volny.cz
Thu Jan 6 16:54:37 UTC 2011


> 06.01.11, 02:40, rozelak at volny.cz:
> > Hallo. Thank you very much for your advice! A have used
> > kde-sunset
> > > > overlayand  KDE3 issues seems to be gone. Unfortunately,
> > > > there
> > > > > > are
> > > > stillmany problems with update from KDE 4.3.3-r1 to 4.4.5:!
> 
> I am not one of kde-sunset overlay maintainers, so I think it's
> better to
> > ask them this question. As far as I understood, the reason -
> start-kde
> > package in official tree is not slotted.

Hallo. i think that problems with KDE 3 (from kde-sunset overlay)
are solved now. The problems which remain are with KDE 4 from
official tree (see the part of output which I added in my previous
mail ...). 

I don't know if "Unsuitable candidates: Found no packages for
resolvent" message is caused by the fact that KDE 4.3.3 is not in
tree now. The 'cave resolve kdebase-startkde -X */kdebase-startkde' 
gives the following result:

!   kde-base/kdebase-startkde
Reasons: !<=kde-base/kdebase-startkde-3.5.10-r3 from
kde-base/kdelibs, !kde-base/kdebase-startkde:4.3[-kdeprefix] from
kde-base/kdebase-startkde
Unsuitable candidates:
* Found no packages for resolvent
kde-base/kdebase-startkde:4.3::(install_to_slash)

Explaining requested decisions:

For kde-base/kdebase-startkde:4.4::(install_to_slash):
The following constraints were in action:
* kde-base/kdebase-startkde, never using existing, installing to /
Because of target
* !<=kde-base/kdebase-startkde-3.5.10-r3, use existing if possible,
installing to /
Because of !<=kde-base/kdebase-startkde-3.5.10-r3 from
kde-base/kdelibs-3.5.10-r6:3.5::installed
The decision made was:
Use origin ID kde-base/kdebase-startkde-4.4.5:4.4::gentoo
Install to repository installed
For kde-base/kdebase-startkde:4.1::(install_to_slash):
The following constraints were in action:
* !kde-base/kdebase-startkde:4.1[-kdeprefix], use existing if
possible, installing to /
Because of !kde-base/kdebase-startkde:4.1[-kdeprefix] from
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
The decision made was:
Do not do anything
For kde-base/kdebase-startkde:4.2::(install_to_slash):
The following constraints were in action:
* !kde-base/kdebase-startkde:4.2[-kdeprefix], use existing if
possible, installing to /
Because of !kde-base/kdebase-startkde:4.2[-kdeprefix] from
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
The decision made was:
Do not do anything
For kde-base/kdebase-startkde:4.3::(install_to_slash):
The following constraints were in action:
* !kde-base/kdebase-startkde:4.3[-kdeprefix], use existing if
possible, installing to /
Because of !kde-base/kdebase-startkde:4.3[-kdeprefix] from
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
* !<=kde-base/kdebase-startkde-3.5.10-r3, use existing if possible,
installing to /
Because of !<=kde-base/kdebase-startkde-3.5.10-r3 from
kde-base/kdelibs-3.5.10-r6:3.5::installed
No decision could be made
For kde-base/kdebase-startkde:4.5::(install_to_slash):
The following constraints were in action:
* !kde-base/kdebase-startkde:4.5[-kdeprefix], use existing if
possible, installing to /
Because of !kde-base/kdebase-startkde:4.5[-kdeprefix] from
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
* !<=kde-base/kdebase-startkde-3.5.10-r3, use existing if possible,
installing to /
Because of !<=kde-base/kdebase-startkde-3.5.10-r3 from
kde-base/kdelibs-3.5.10-r6:3.5::installed
The decision made was:
Do not do anything
For kde-base/kdebase-startkde:4.6::(install_to_slash):
The following constraints were in action:
* !kde-base/kdebase-startkde:4.6[-kdeprefix], use existing if
possible, installing to /
Because of !kde-base/kdebase-startkde:4.6[-kdeprefix] from
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
The decision made was:
Do not do anything
For kde-base/kdebase-startkde:live::(install_to_slash):
The following constraints were in action:
* !kde-base/kdebase-startkde:live[-kdeprefix], use existing if
possible, installing to /
Because of !kde-base/kdebase-startkde:live[-kdeprefix] from
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
The decision made was:
Do not do anything
For kde-base/kdebase-startkde:3.5::(install_to_slash):
The following constraints were in action:
* !<=kde-base/kdebase-startkde-3.5.10:3.5, use existing if possible,
installing to /
Because of !<=kde-base/kdebase-startkde-3.5.10:3.5 from
kde-base/kdelibs-4.4.5:4.4::gentoo
* !<=kde-base/kdebase-startkde-3.5.10-r3, use existing if possible,
installing to /
Because of !<=kde-base/kdebase-startkde-3.5.10-r3 from
kde-base/kdelibs-3.5.10-r6:3.5::installed
The decision made was:
Use existing ID kde-base/kdebase-startkde-3.5.10-r5:3.5::installed


How to read it?  How to instruct paludis just to ignore KDE 3.5 and
update KDE 4.* Where kdebase-startkde-3.5.10-r3 comes from if  'cave
search kdebase-starkde'
gives the following result:

* kde-base/kdebase-startkde
::gentoo                  4.4.5* {:4.4} (4.5.3)K (4.5.4)K {:4.5}
::installed               3.5.10-r5 {:3.5} 4.3.3-r1 {:4.3}
::kde-sunset              3.5.10-r5 {:3.5}
kde-base/kdebase-startkde-4.4.5:4.4::gentoo
Description           Startkde script, which starts a complete KDE
session, and associated scripts
Homepage              http://www.kde.org/


I must have something horribly broken on the computer. But what can
it be??

Thank you very much. Best regards,
Dan T.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20110106/4b0a822f/attachment.html>


More information about the paludis-user mailing list