[paludis-user] pygtk fails to build. Three packages needed are removed by an uninstall-unused

Robert T Childers trent-ch at cox.net
Mon May 17 21:50:10 UTC 2010


On Monday 17 May 2010 05:38:18 Ciaran McCreesh wrote:
> On Sun, 16 May 2010 18:33:28 -0500
> 
> Robert T Childers <trent-ch at cox.net> wrote:
> > I was doing some system maintenance and in the course of the updates
> > and cleaning of unused packages, I removed libonoboui, libgnomeui and
> > libgnomecanvas. This caused pygtk to fail to build. reinstalling them
> > causes pygtk to build correctly, but paludis -1i pygtk doesn't pull
> > in those three as dependencies. And all three still show up as not
> > used by any package in world.
> 
> Paludis just goes by what the ebuild dependencies say, which suggests
> that this is an ebuild bug.

Yes, I agree with you on this point. Thats why I am in the process of tracing 
out the dependency tree on this. I do have a question for you though. when 
paludis examines the ebuild for pygtk, and notes that it requires dev-
libs/glib, with dev-libs/glib present does it continue to walk the tree and 
check all the dependencies of dev-libs/glib?



More information about the paludis-user mailing list