[paludis-user] Webmin install error

Bo Ørsted Andresen bo.andresen at zlin.dk
Tue May 4 13:55:57 UTC 2010


On Friday 30 April 2010 11:36:24 Ciaran McCreesh wrote:
> >    * When installing 'app-admin/webmin-1.500:0::gentoo':
> >    * When fetching mtime of
> > 
> > '/var/tmp/paludis/app-admin-webmin-1.500/temp/build_start_time':
> >    * Filesystem entry
> > 
> > '/var/tmp/paludis/app-admin-webmin-1.500/temp/build_start_time' does
> > not exist (paludis::FSError)
> > 
> > This one has me completely stumped! Whats gone wrong,
> > I've tried installing something else and there was no problem.
> 
> I'm guessing something the ebuild does clobbers everything in ${T},
> including the file we put there to track when the build started. I'm not
> entirely sure whether that's legal for an ebuild to do or not...

The ebuild runs export tempdir="${T}" and then calls a setup.sh in 
src_install. setup.sh calls a maketemp.pl perl script which uses 
tempdir=/tmp/.webmin if no tempdir is specified. If the specified tempdir exists 
and doesn't meet a set of requirements it nukes it and recreates it. So 
changing the ebuild to export tempdir="${T}/.webmin" would probably fix it.

-- 
Bo Andresen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20100504/121a3853/attachment.asc>


More information about the paludis-user mailing list