[paludis-user] Fwd: gvfs requires liblzmadec.so.0

Damian damian.only at gmail.com
Tue Feb 9 15:05:26 UTC 2010


It seems like the problem is in the ebuild itself.


---------- Forwarded message ----------
From: Damian <damian.only at gmail.com>
Date: Mon, Feb 8, 2010 at 7:18 PM
Subject: Re: [paludis-user] gvfs requires liblzmadec.so.0
To: ian at leehouse.eclipse.co.uk


On Mon, Feb 8, 2010 at 6:47 PM, Ian Lee <ian at leehouse.eclipse.co.uk> wrote:
> Damian wrote:
>>
>> On Mon, Feb 8, 2010 at 1:36 PM, Ian Lee <ian at leehouse.eclipse.co.uk>
>> wrote:
>>>
>>> Damian wrote:
>>>>
>>>> After I ran reconcilio, I found the following problem:
>>>> gnome-base/gvfs-1.2.3::installed
>>>>   /usr/libexec/gvfsd-archive (requires liblzmadec.so.0)
>>>>
>>>> But when installing gvfs, the compilation aborts with the following
>>>> error:
>>>>   x86_64-pc-linux-gnu-gcc: /usr/lib64/liblzmadec.so: No such file or
>>>> directory
>>>>
>>>> I've filled a bug report in gentoo bugzilla, but there was no solution
>>>> yet. I was wondering whether there may be a workaround to this.
>>>>
>>>> Here is the error output: http://pastebin.com/m5a473476
>>>>
>>>> Thanks in advance.
>>>> _______________________________________________
>>>> paludis-user mailing list
>>>> paludis-user at lists.pioto.org
>>>> http://lists.pioto.org/mailman/listinfo/paludis-user
>>>
>>> Try updating libarchive to 2.7.1-r1
>>
>> I'm still getting the same error.
>
>
> OK start from the beginnng :)
Thanks :)

> 1) Is the lzma use flag enabled on app-archive/libarchive?
Yes:

* app-arch/libarchive
   gentoo:                  2.7.0-r1 2.7.1-r1 (2.7.902a)KR {:0}
   installed:               2.7.1-r1* {:0}
   Description:             BSD tar command
   Homepage:                http://people.freebsd.org/~kientzle/libarchive
   License:                 BSD
   Installed time:          Mon Feb 08 14:00:49 CET 2010
   Use flags:               (acl) (bzip2) (lzma) (-static)
(-static-libs) (-xattr) (zlib) Build Options: -trace
   From repositories:       gentoo
   Installed using:         paludis-0.44.1

> 2) Have you got lzma-utils, xz-utils or neither installed?
The deprecated lzma-utils is not istalled, only app-arch/xz-utils.

> 3) What is the output of `ldd /usr/libexec/gvfsd-archive` ?
       linux-vdso.so.1 =>  (0x00007fffe331a000)
       libgvfscommon.so.0 => /usr/lib/libgvfscommon.so.0 (0x00007fb3ce6bd000)
       libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007fb3ce4b8000)
       libpthread.so.0 => /lib/libpthread.so.0 (0x00007fb3ce29c000)
       librt.so.1 => /lib/librt.so.1 (0x00007fb3ce093000)
       libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007fb3cddec000)
       libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007fb3cdba7000)
       libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007fb3cd9a3000)
       libdl.so.2 => /lib/libdl.so.2 (0x00007fb3cd79f000)
       libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007fb3cd4ba000)
       libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007fb3cd280000)
       libarchive.so.2 => /lib/libarchive.so.2 (0x00007fb3cd04a000)
       libacl.so.1 => /lib/libacl.so.1 (0x00007fb3cce42000)
       libattr.so.1 => /lib/libattr.so.1 (0x00007fb3ccc3c000)
       libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0x00007fb3cc8b2000)
       liblzmadec.so.0 => not found
       libbz2.so.1 => /lib/libbz2.so.1 (0x00007fb3cc6a2000)
       libz.so.1 => /lib/libz.so.1 (0x00007fb3cc48d000)
       libutil.so.1 => /lib/libutil.so.1 (0x00007fb3cc28a000)
       libc.so.6 => /lib/libc.so.6 (0x00007fb3cbf31000)
       /lib64/ld-linux-x86-64.so.2 (0x00007fb3ce8d4000)
       libresolv.so.2 => /lib/libresolv.so.2 (0x00007fb3cbd1a000)
       liblzma.so.0 => /usr/lib/liblzma.so.0 (0x00007fb3cbaf8000)



More information about the paludis-user mailing list