[paludis-user] Strange errors when updating

rozelak at volny.cz rozelak at volny.cz
Thu Dec 23 13:35:32 UTC 2010


Hallo everybody. 

I would like to ask what the following errors mean and how to fix
them. When I invoke 'paludis -ip world', the result looks as shown
at the end of the mail, with many errors of various kind listed. 

Strange is, for example, the error: 
Ignoring run dependencies due to exception 'Error searching for
'kde-base/arts': no available versions'
(paludis::AllMaskedError) 

although I have kde-base/arts not installed. There is also no 'arts'
USE flag defined.

This error:
No visible packages matching 'virtual/glut', falling back to
installed package 'virtual/glut-1.0::installed' also looks strange.

Looking at the installed packages, I see nothing suspicious:

##cave search glut

* media-libs/freeglut
::gentoo                  2.4.0-r1 2.6.0* {:0}
::installed               2.6.0 {:0}
media-libs/freeglut-2.6.0:0::gentoo
Description           A completely OpenSourced alternative to the
...
* virtual/glut
::installed               1.0 {:0}
virtual/glut-1.0:0::installed
Description           Virtual for OpenGL utility toolkit


Do you know what can be wrong with it? Could you, please, help me to
fix it? Do you need any additional information which I could send to
you.

I am using paludis-0.54.8, but I am sure that the errors occurred
with the previous versions as well.

Thank you very much your help. Kind regards,
Dan T.

---
The output of 'paludis -ip world':

Building target list...
Building dependency list: ... 140 ste 141 steps1293111211: [WARNING
dep_list.no_visible] In thread ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'app-crypt/pinentry':
... When adding installed package
'app-crypt/pinentry-0.8.0:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=x11-libs/qt-gui-4.4.1':
... When adding installed package
'x11-libs/qt-gui-4.6.2:4::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'net-print/cups':
... When adding installed package
'net-print/cups-1.3.11-r1:0::installed':
... When adding post dependencies as post dependencies unless under
a suggested label:
... When adding PackageDepSpec 'app-text/ghostscript-gpl':
... When adding installed package
'app-text/ghostscript-gpl-8.71-r4:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'media-libs/jasper':
... When adding installed package
'media-libs/jasper-1.900.1-r3:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'virtual/glut':
... No visible packages matching 'virtual/glut', falling back to
installed package 'virtual/glut-1.0::installed'
155 stepspaludis at 1293111212:dep_list.no_visible]  156 stepsIn thread
ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'app-crypt/pinentry':
... When adding installed package
'app-crypt/pinentry-0.8.0:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=x11-libs/qt-gui-4.4.1':
... When adding installed package
'x11-libs/qt-gui-4.6.2:4::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'net-print/cups':
... When adding installed package
'net-print/cups-1.3.11-r1:0::installed':
... When adding post dependencies as post dependencies unless under
a suggested label:
... When using already installed group to resolve dependencies:
... When adding PackageDepSpec 'net-print/hplip':
... When adding installed package
'net-print/hplip-3.10.5:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec
'>=net-print/foomatic-filters-3.0.20080507[cups]':
... When adding installed package
'net-print/foomatic-filters-3.0.20080507:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'virtual/ghostscript':
... No visible packages matching 'virtual/ghostscript', falling back
to installed package 'virtual/ghostscript-0::installed'
158 stepspaludis at 1293111212: [WARNING dep_list.no 159 stepsIn thread
ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'app-crypt/pinentry':
... When adding installed package
'app-crypt/pinentry-0.8.0:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=x11-libs/qt-gui-4.4.1':
... When adding installed package
'x11-libs/qt-gui-4.6.2:4::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'net-print/cups':
... When adding installed package
'net-print/cups-1.3.11-r1:0::installed':
... When adding post dependencies as post dependencies unless under
a suggested label:
... When using already installed group to resolve dependencies:
... When adding PackageDepSpec 'net-print/hplip':
... When adding installed package
'net-print/hplip-3.10.5:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'net-analyzer/net-snmp':
... When adding installed package
'net-analyzer/net-snmp-5.4.2.1-r1:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '=sys-apps/lm_sensors-2*':
... No visible packages matching '=sys-apps/lm_sensors-2*', falling
back to installed package 'sys-apps/lm_sensors-2.10.7::installed'
201 stepspaludis at 1293111214: [WARNING
dep_list.ignoring_dependencies] In thread ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'app-crypt/pinentry':
... When adding installed package
'app-crypt/pinentry-0.8.0:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=x11-libs/qt-gui-4.4.1':
... When adding installed package
'x11-libs/qt-gui-4.6.2:4::installed':
... When adding post dependencies as post dependencies unless under
a suggested label:
... When adding PackageDepSpec
'~x11-libs/qt-qt3support-4.6.2[aqua=,debug=]':
... When adding installed package
'x11-libs/qt-qt3support-4.6.2:4::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec
'media-sound/phonon[aqua=,gstreamer]':
... When adding installed package
'media-sound/phonon-4.3.80-r1:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec
'media-plugins/gst-plugins-meta[alsa?]':
... When adding installed package
'media-plugins/gst-plugins-meta-0.10-r4:0.10::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec
'>=media-plugins/gst-plugins-mpeg2dec-0.10':
... When adding installed package
'media-plugins/gst-plugins-mpeg2dec-0.10.13:0.10::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=media-libs/libmpeg2-0.4':
... When adding installed package
'media-libs/libmpeg2-0.5.1:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'media-libs/libsdl':
... When adding installed package
'media-libs/libsdl-1.2.13-r1:0::installed':
... Ignoring run dependencies due to exception 'Error searching for
'kde-base/arts': no available versions' (paludis::AllMaskedError)
344 st 345 steps at 1293111221: [WARNING dep_list.no_visible] In thread
ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'app-editors/vim':
... When adding installed package
'app-editors/vim-7.2.303:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '~app-editors/vim-core-7.2.303':
... No visible packages matching '~app-editors/vim-core-7.2.303',
falling back to installed package
'app-editors/vim-core-7.2.303::installed'
349 stepspaludis at 1293111221: [WARNING
dep_list.ignoring_dependencies] In thread ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'app-emulation/virtualbox-bin':
... When adding installed package
'app-emulation/virtualbox-bin-3.2.0:0::installed':
... Ignoring run dependencies due to exception 'Error searching for
'~app-emulation/virtualbox-modules-3.2.0': no available versions'
(paludis::AllMaskedError)
432 stepspaludis@ 433 steps: [WARNING dep_list.no_visible] In thread
ID '8913':
... In program paludis (--dl-upgrade as-needed) -ip world:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding NamedSetDepSpec 'world':
... When adding NamedSetDepSpec 'world::environment':
... When adding PackageDepSpec 'kde-base/kmail':
... When adding installed package
'kde-base/kmail-4.4.3:4.4::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec
'>=kde-base/kdepimlibs-4.4.3[aqua=,-kdeprefix,akonadi]':
... No visible packages matching
'>=kde-base/kdepimlibs-4.4.3[aqua=,-kdeprefix,akonadi]', falling
back to installed package 'kde-base/kdepimlibs-4.4.3:4.4::installed'
705 steps, 1 metadata (1 overlay-local)

These packages will be installed:


Total: 0 packages

Checking for possible errors......

* No unread news items found

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20101223/8a16b75b/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: attachment
URL: <http://lists.exherbo.org/pipermail/paludis-user/attachments/20101223/8a16b75b/attachment.ksh>


More information about the paludis-user mailing list