[paludis-user] QT packages block themselves from updating

David Watzke david at watzke.cz
Sun Oct 11 06:49:10 UTC 2009


Yes, --dl-blocks discard is safe. You have to realize that you don't have much 
of a choice here. Block's here because i.e. newer qt-core won't work with 
older qt-gui, and so on. So you've got two options. Discarding blocks will 
just upgrade all the Qt modules, one at the time and during this some Qt apps 
won't work for a while. Or you can permit unsafe uninstalls, drop all the Qt 
modules and install the new ones... but Qt apps won't work until it's all 
installed again, obviously.

K. Larsen wrote:
> Hi all!
> 
> Recently I've been seeing a lot of blocks when trying to update my system.
> 
> Here is a portion of the output from # paludis -ip world :
> 
> These packages will be installed:
> 
> * x11-libs/qt-xmlpatterns::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 9 more
> * x11-libs/qt-webkit::installed :4 [! 4.5.1-r1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 7 more
> * x11-libs/qt-test::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 5 more
> * x11-libs/qt-svg::installed :4 [! 4.5.1-r1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 8 more
> * x11-libs/qt-sql::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 3 more
> * x11-libs/qt-script::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-script-4.5.2:4::gentoo
> * x11-libs/qt-qt3support::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 3 more
> * x11-libs/qt-opengl::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 6 more
> * x11-libs/qt-gui::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-gui-4.5.2-r2:4::gentoo
> * x11-libs/qt-dbus::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo,
> x11-libs/qt-dbus-4.5.2:4::gentoo, 1 more
> * x11-libs/qt-core::installed :4 [! 4.5.1 blocking]
>     Reasons: x11-libs/qt-core-4.5.2:4::gentoo
> 
> As you can see, the root cause is that the packages are blocking
> themselves.  I saw something in the list archives about this from a
> few months ago, and it was mentioned that portage has a bug that will
> cause it to ignore a block on a package if it is due to that same
> package.  The apparent solution was to install the new version and
> then remove the version that blocks.
> 
> How should I go about this?  Is "--dl-blocks discard" safe in this
>  instance?
> 
> Thanks,
> Kameron
> _______________________________________________
> paludis-user mailing list
> paludis-user at lists.pioto.org
> http://lists.pioto.org/mailman/listinfo/paludis-user
> 



More information about the paludis-user mailing list