[paludis-user] Paludis update problem

Ward Poelmans wpoely86 at gmail.com
Thu Oct 1 21:12:36 UTC 2009


On Thu, Oct 1, 2009 at 22:12, Ian Lee <ian at leehouse.eclipse.co.uk> wrote:
> I have the same error too with lvm2.
>
>  I am going to assume that as baselayout is installed and fails the first
> dependency paludis' dependency checks blocks the package.
>
>
> This is a work around this problem
>
> || ( >=sys-apps/openrc-0.4 =sys-apps/baselayout-1*  )
>
>
> So out of interest I had a search for the || block specification but I
> couldn't find much detail. whats is the defined behavior? Is this a bad
> ebuild?

Well, i can't find much about it neither except that the the order of
the package should not matter. I shall try your suggestion.

> For the sys-fs/device-mapper block, --dl-block discard ignores it.
> Though after reading the pms-2 pdf I would like to ask what the correct
> solution??
>
> Should I uninstall sys-fs/device-mapper first as implied by the strong(!!)
> block

Yes, you should uninstall it. Device-mapper has been merged into lvm2,
so you don't need it as a separate package.

Ward

PS. You answer to me instead of the list.



More information about the paludis-user mailing list