[paludis-user] Paludis update problem

Ward Poelmans wpoely86 at gmail.com
Thu Oct 1 17:06:15 UTC 2009


Hi,

I've got a problem when updating lvm2 and udev. I don't know if it is
a paludis issue or ebuild issue so i will just ask. Currently i have
lvm2-2.02.42 and udev-141-r1 installed. When i want to upgrade
lvm2-2.02.51-r1 and udev-146, i first have to uninstall device-mapper
as it has merged in the lvm2 tree in version 2.02.44. After done that,
i get this:
paludis -pi lvm2
Building target list...
Building dependency list: ... 19 stepspaludis at 1254416459: [WARNING
dep_list.downgrade] In thread ID '14698':
  ... In program paludis -pi lvm2:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'sys-fs/lvm2':
  ... When adding package 'sys-fs/lvm2-2.02.51-r1:0::gentoo':
  ... When adding run dependencies as pre dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec '=sys-apps/baselayout-1*':
  ... Downgrade to 'sys-apps/baselayout-1.12.12:0::gentoo' from
'sys-apps/baselayout-2.0.1:0::installed' forced
 258 stepspaludis at 1254416462: [WARNING dep_list.ignoring_dependencies]
In thread ID '14698':
  ... In program paludis -pi lvm2:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'sys-fs/lvm2':
  ... When adding package 'sys-fs/lvm2-2.02.51-r1:0::gentoo':
  ... When adding run dependencies as pre dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec '=sys-apps/baselayout-1*':
  ... When adding package 'sys-apps/baselayout-1.12.12:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=sys-apps/portage-2.0.51':
  ... When adding installed package 'sys-apps/portage-2.1.6.13:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=dev-lang/python-2.5':
  ... When adding installed package 'dev-lang/python-3.1.1-r1:3.1::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=app-admin/eselect-python-20080925':
  ... When adding installed package
'app-admin/eselect-python-20090824:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=app-admin/eselect-1.0.2':
  ... When adding installed package 'app-admin/eselect-1.2.3:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec 'sys-apps/coreutils':
  ... When adding installed package 'sys-apps/coreutils-7.6:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'sys-libs/libcap':
  ... When adding installed package 'sys-libs/libcap-2.17:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'virtual/pam':
  ... When adding installed package
'virtual/pam-1.1.0::installed-virtuals (virtual for
sys-libs/pam-1.1.0:0::installed)':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'sys-libs/pam':
  ... When adding installed package 'sys-libs/pam-1.1.0:0::installed':
  ... When adding post dependencies as post dependencies unless under
a suggested label:
  ... When adding PackageDepSpec 'sys-auth/pambase':
  ... When adding installed package
'sys-auth/pambase-20090620.1-r1:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=gnome-base/gnome-keyring-2.20[pam]':
  ... When adding installed package
'gnome-base/gnome-keyring-2.26.3:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=x11-libs/gtk+-2.6':
  ... When adding installed package 'x11-libs/gtk+-2.16.6:2::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'net-print/cups':
  ... When adding installed package 'net-print/cups-1.4.1:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec 'net-dns/avahi[mdnsresponder-compat]':
  ... When adding installed package 'net-dns/avahi-0.6.25:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec 'x11-libs/qt-core:4':
  ... When adding installed package 'x11-libs/qt-core-4.5.2:4::installed':
  ... When adding post dependencies as post dependencies unless under
a suggested label:
  ... When adding PackageDepSpec '~x11-libs/qt-gui-4.5.2[qt3support]':
  ... When adding installed package 'x11-libs/qt-gui-4.5.2-r2:4::installed':
  ... When adding post dependencies as post dependencies unless under
a suggested label:
  ... When adding PackageDepSpec '~x11-libs/qt-qt3support-4.5.2[debug=]':
  ... When adding installed package 'x11-libs/qt-qt3support-4.5.2:4::installed':
  ... When adding run dependencies as post dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec 'media-sound/phonon[gstreamer]':
  ... When adding installed package
'media-sound/phonon-4.4_pre20090520:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=media-libs/xine-lib-1.1.15-r1[xcb?]':
  ... When adding installed package
'media-libs/xine-lib-1.1.16.3-r1:1::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=gnome-base/gnome-vfs-2.0':
  ... When adding installed package 'gnome-base/gnome-vfs-2.24.1:2::installed':
  ... When adding post dependencies as post dependencies unless under
a suggested label:
  ... When adding PackageDepSpec '>=gnome-base/gnome-mount-0.6':
  ... When adding installed package
'gnome-base/gnome-mount-0.8-r1:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=gnome-base/nautilus-2.21.2':
  ... When adding installed package 'gnome-base/nautilus-2.26.4:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=gnome-base/gnome-desktop-2.25.5':
  ... When adding installed package
'gnome-base/gnome-desktop-2.26.3:0::installed':
  ... When adding post dependencies as post dependencies unless under
a suggested label:
  ... When adding PackageDepSpec '>=dev-python/pygtk-2.8':
  ... When adding installed package 'dev-python/pygtk-2.16.0-r1:2::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'dev-python/numpy':
  ... When adding installed package 'dev-python/numpy-1.3.0-r1:0::installed':
  ... Ignoring run dependencies due to exception 'Block:
<dev-python/setuptools-0.6.3-r2' (paludis::BlockError)
 388 steps
Dependency error:
  * In program paludis -pi lvm2:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'sys-fs/lvm2':
  * When adding package 'sys-fs/lvm2-2.02.51-r1:0::gentoo':
  * When adding run dependencies as post dependencies:
  * When checking BlockDepSpec '!!sys-fs/device-mapper':
  * Block: sys-fs/device-mapper (paludis::BlockError)

This is strange for 2 reasons:
First, it want to downgrade baselayout from 2.x to 1.x. In the lvm2
ebuild it says:
RDEPEND="${DEPEND}
        || ( =sys-apps/baselayout-1* >=sys-apps/openrc-0.4 )
        !sys-fs/lvm-user
        !sys-fs/clvm"

As openrc-0.4.3-r3 is installed, it should not downgrade baselayout.
Second, it gives a block on device-mapper, which is uninstalled (i
check with paludis -q device-mapper).
When i do emerge -pv lvm2, it does what i expect: just upgrade lvm2
with a problem.

So, any ideas what goes wrong?

Thanks in advance,

Ward



More information about the paludis-user mailing list