[paludis-user] git-1.6.2.3 wants to downgrade subversion

denisgolovan denisgolovan at yandex.ru
Tue Apr 28 05:59:28 UTC 2009


Hi all 

I'm experiencing some strange behaviour. 
git-1.6.2.3 wants to downgrade subversion from 1.5.5 down to 1.4.6 

Taking a brief look at both subversion and git ebuild does not show any version dependencies hardcoded. 

P.S. I'm using paludis 0.36.1 

P.P.S 
* dev-util/subversion 
bazaar: 1.3.2-r4 1.4.6 {:0} 
gentoo: 1.5.5 1.5.6 (1.6.0-r1)K (1.6.1)K {:0} 
installed: 1.5.5* {:0} 
funtoo: 1.5.5 (1.5.6)K (1.6.0-r1)K (1.6.1)K {:0} 
Description: Advanced version control system 
Homepage: http://subversion.tigris.org/ 
License: Subversion 
Installed time: Tue Apr 21 17:35:05 2009 
Use flags: (-apache2) (bash-completion) (berkdb) (-debug) (-doc) (dso) (emacs) (-extras) (-java) (nls) (perl) (python) (-ruby) (-sasl) (-vim-syntax) (webdav-neon) (-webdav-serf) 
>From repositories: funtoo 
Installed using: paludis-0.36.0 

dev-util/git 
gentoo: 1.5.1.6 1.5.3.7-r1 1.5.3.8(~) 1.5.4.5 1.5.5.3(~) 1.5.5.3-r1(~) 1.5.5.4(~) 1.5.6.1(~) 1.5.6.2(~) 1.5.6.3(~) 1.5.6.4 1.5.6.5(~) 1.6.0(~) 1.6.0.1(~) 1.6.0.2(~) 1.6.0.3(~) 1.6.0.4(~) 1.6.0.4-r1(~) 1.6.0.4-r2(~) 1.6.0.6 1.6.1(~) 1.6.1.1(~) 1.6.1.2(~) 1.6.1.3(~) 1.6.2(~) 1.6.2.2(~) 1.6.2.2-r1(~) 1.6.2.3(~) (9999)KU {:0} 
funtoo: 1.6.0.1(~) 1.6.0.6 1.6.1-r1(~) 1.6.1.1(~) 1.6.1.2(~) 1.6.1.3(~) 1.6.2 1.6.2.2(~) 1.6.2.2-r1(~) 1.6.2.3(~) (9999)KU {:0} 
installed: 1.6.2.3* {:0} 
zen-overlay: (9999)KU {:0} 
Description: GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team 
Homepage: http://www.git-scm.com/ 
License: GPL-2 
Installed time: Sun Apr 19 06:10:57 2009 
Use flags: (bash-completion) (-cgi) (-curl) (cvs) (-doc) (emacs) (-gtk) (iconv) (-mozsha1) (perl) (-ppcsha1) (subversion) (-threads) (-tk) (-webdav) (-xinetd) 
>From repositories: gentoo 
Installed using: paludis-0.36.0 

-- 
Regards, 
Denis Golovan aka MageSlayer




More information about the paludis-user mailing list