[paludis-user] Help resolving block

Tom Cooksey tomcooksey at googlemail.com
Wed Apr 22 06:57:29 UTC 2009


Could anyone please help & explain how I can resolve the following block:

Dependency error:
  * In program paludis --install world --continue-on-failure if-satisfied -p:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding NamedSetDepSpec 'world':
  * When adding PackageDepSpec 'kde-base/kdebase-meta:4.2':
  * When adding package 'kde-base/kdebase-meta-4.2.2:4.2::gentoo':
  * When adding run dependencies as post dependencies:
  * When adding PackageDepSpec '>=kde-base/dolphin-4.2.2:4.2':
  * When adding package 'kde-base/dolphin-4.2.2:4.2::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec
'>=kde-base/kdelibs-4.2.2:4.2[kdeprefix=,semantic-desktop=]':
  * When adding package 'kde-base/kdelibs-4.2.2-r1:4.2::gentoo':
  * When adding run dependencies as post dependencies:
  * When checking BlockDepSpec '!<=kde-misc/kdnssd-avahi-0.1.2:0':
  * Block: <=kde-misc/kdnssd-avahi-0.1.2:0 (paludis::BlockError)


I have uninstalled "kde-misc/kdnssd-avahi", but I wonder if kdelibs
3.5 is pulling it back into the dependency tree?


Cheers,

Tom



More information about the paludis-user mailing list