[paludis-user] gtk+ and cairo problems

Vasiliy G Tolstov v.tolstov at selfip.ru
Wed Oct 22 21:00:49 UTC 2008


Hello!
I'm using exherbo, when i'm try to install gtk+ or cairo' i have error
about circular depencies:

home / # paludis -i -p cairo
Building target list... 
Building dependency list...
Dependency error:
  * In program paludis -i -p cairo:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'x11-libs/cairo':
  * When adding package 'x11-libs/cairo-1.8.0:0::x11':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'x11-libs/gtk+:2':
  * When adding package 'x11-libs/gtk+-2.14.3:2::gnome':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec '>=x11-libs/cairo-1.6[X][pdf]':
  * Circular dependency: Atom '>=x11-libs/cairo-1.6[X][pdf]' matched by
merge list entry 'x11-libs/cairo-1.8.0:0::x11', which does not yet have
its dependencies installed (paludis::CircularDependencyError)

home / # cat /etc/paludis/options.conf 
*/* -bash-completion nls freetype -pam unicode ipv6 X pdf python svg xcb
doc
sys-apps/paludis inquisitio vim-syntax
app-text/poppler glib

How can i install this packages ?

-- 
Vasiliy G Tolstov <v.tolstov at selfip.ru>
Selfip.Ru




More information about the paludis-user mailing list