[paludis-user] Uninstalling portage

Benjamin R. Haskell paludis at benizi.com
Sat Oct 11 14:28:32 UTC 2008


On Sat, 11 Oct 2008, Dirk Heinrichs wrote:

> Hi,
>
> I've noticed there's a virtual/portage now, so I tried uninstalling sys- 
> apps/portage and got this:
>
> # paludis --uninstall -p portage
> Building unmerge list... done
>
> These packages will be uninstalled:
>
> * app-accessibility/freetts-1.2.1-r1::installed requires <sys-apps/portage-2.2_rc12::installed>
> * app-admin/python-updater-0.6::installed requires <sys-apps/portage-2.2_rc12::installed>
> * app-portage/gentoolkit-0.2.4.2::installed requires <sys-apps/portage-2.2_rc12::installed>
> * app-portage/udept-0.5.99.0.2.95-r1::installed requires <sys-apps/portage-2.2_rc12::installed>
> * dev-java/ant-core-1.7.1-r1::installed requires <sys-apps/portage-2.2_rc12::installed>
> * dev-java/sun-jdk-1.6.0.07-r1::installed requires <sys-apps/portage-2.2_rc12::installed>
> * kde-base/kdelibs-3.5.9-r4:3.5::installed requires <sys-apps/portage-2.2_rc12::installed>
> * sys-libs/glibc-2.8_p20080602::installed requires <sys-apps/portage-2.2_rc12::installed>
> * sys-apps/portage-2.2_rc12::installed
>
> I can understand that udept, gentoolkit and python-updater apear on the list,
> but what in hell makes kdelibs, sun-jdk or even glibc depend on portage???
>
> /me scratching head.
>
> Bye...
>
> 	Dirk


Interesting also is that <=sys-libs/glibc-2.6.1 doesn't have that 
dependency.

glibc is very tricky to upgrade, since almost everything depends on it. 
(That's at least been my past experience -- it's been a while since I did 
it without a package manager. But it was always something I was loathe to 
upgrade on a remote server.)

So, my guess is that, to deal with the installation trickiness, portage 
uses workarounds for newer glibc's that aren't available in earlier 
versions of portage. (...though nothing looked crazy in a quick glance at 
the glibc ChangeLog and 2.8_p20080602 ebuild. Anyone know what 'eblits' 
are?)

I'd also guess that a more appropriate thing to put in DEPEND would be:

!<sys-apps/portage-2.1.2

(I'm assuming you didn't install glibc-2.8_p20080602 with portage.)

Best,
Ben



More information about the paludis-user mailing list