[paludis-user] downgrade forced, but nothing is downgraded

Tom Cooksey tomcooksey at googlemail.com
Fri Oct 10 22:21:23 UTC 2008


> I also encountered the problem via poppler, and fixed it by masking the
> unneeded qt.
>
> $ grep qt /etc/paludis/package_mask.conf
> <x11-libs/qt-4.4:4

I also had the problem that qt downgrade was forced by
app-text/poppler-bindings (& fixed it the same way). The crazy thing I
found was that it would keep downgrading then upgrading then
downgrading every time I ran paludis --install world.

After looking at the src, I think it's the poppler-bindings ebuild
which is at fault:

RDEPEND="~app-text/poppler-${PV}
	cairo? ( >=x11-libs/cairo-1.4 )
	gtk? (
		>=x11-libs/gtk+-2.8
		>=gnome-base/libglade-2
	)
	qt3? ( =x11-libs/qt-3* )
	qt4? ( || ( ( x11-libs/qt-core:4
			x11-libs/qt-gui:4
			x11-libs/qt-test:4 )
		=x11-libs/qt-4.3*:4 ) )"

I'm no ebuild expert, but I believe the last line is a bit suspect?
Surely this should be >=x11-libs/qt-4.3*:4 ? Or is that there because
Qt 4.4 uses split packages whereas 4.3 doesn't and the line is to
catch older, non-split 4.3 Qt versions?

I've had a similar problem with ffmpeg (being repeatedly downgraded
then upgraded again) but I can't remember the exact circumstances or
which packages were causing the up/down-grade.


Cheers,

Tom



More information about the paludis-user mailing list