[paludis-user] downgrade forced, but nothing is downgraded

Benjamin R. Haskell paludis at benizi.com
Fri Oct 10 20:01:18 UTC 2008


> > -----Original Message-----
> > Subject: Re: [paludis-user] downgrade forced, but nothing is downgraded
> >
> > On Fri, 10 Oct 2008 17:42:59 +0200
> > Raimar Sandner <lists at 404not-found.de> wrote:
> > > But nevertheless I don't understand the following: I have upgraded 
> > > x11-libs/qt from 4.3.5 to 4.4.2, now I get:
> > <snip>
> > > So what is the downgrade warning all about?
> >
> > The resolver's being stupid. Reinstalling the appropriate packages 
> > with the use flags changed as per the deps will fix it.
> >
> > --
> > Ciaran McCreesh
> >

On Fri, 10 Oct 2008, David Pyke wrote:

> I don't know if that will fix it.  I've been getting the same issue due 
> to poppler-bindings and have ignored it as it hasn't actually done 
> anything.
>
> I've re-installed (and upgraded) poppler and all its wonders and am 
> still getting the warning.
> __________________
> David Pyke

I also encountered the problem via poppler, and fixed it by masking the 
unneeded qt.

$ grep qt /etc/paludis/package_mask.conf
<x11-libs/qt-4.4:4

Best,
Ben



More information about the paludis-user mailing list