[paludis-user] No package available for ..

Ciaran McCreesh ciaran.mccreesh at googlemail.com
Fri Oct 3 23:54:54 UTC 2008


On Sat, 4 Oct 2008 12:50:37 +1300
John Huttley <john at mib-infotech.co.nz> wrote:
> Can anyone say what this means? (during the start of an install, for
> any package)
> 
> It doesn't seem to stop things from working.
> 
> I run half a dozen systems and they all complain about something,
> usually the kernel, one about clamav.
> 
>   ... When finding provided packages for 'installed':
>   ... No package available for 'sys-kernel/gentoo-sources 2.6.25-r1'
> paludis at 1223077529: [WARNING e.vdb.provides.no_package] (same
> context) No package available for 'sys-kernel/gentoo-sources
> 2.6.25-r4'

It means your provides cache is out of date. This most commonly happens
if you mix Portage and Paludis usage, although it can also be caused by
Gentoo developers screwing around with metadata in weird ways.

You can probably fix it by paludis --regenerate-installed-cache.

-- 
Ciaran McCreesh



More information about the paludis-user mailing list